aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2019-02-20 18:09:50 +0100
committerAlexander Couzens <lynxis@fe80.eu>2019-02-24 01:48:25 +0100
commitb7f2adbdd3ed76e9c844b99d0171c9bfe5809cba (patch)
treef82a98a07e42db59c3b0a3195465f257bf8c87ff /package/network/services/dnsmasq
parent77a54bbf13bf2a798cfdfc8dd6c61759ac18a19f (diff)
downloadupstream-b7f2adbdd3ed76e9c844b99d0171c9bfe5809cba.tar.gz
upstream-b7f2adbdd3ed76e9c844b99d0171c9bfe5809cba.tar.bz2
upstream-b7f2adbdd3ed76e9c844b99d0171c9bfe5809cba.zip
package/dnsmasq: add max_ttl/min_cache_ttl/max_cache_ttl
max_ttl - limit the ttl in the dns answer if greater as $max_ttl min_cache_ttl - force caching of dns answers even the ttl in the answer is lower than the $min_cache_ttl max_cache_ttl - cache only dns answer for $max_cache_ttl. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'package/network/services/dnsmasq')
-rw-r--r--package/network/services/dnsmasq/Makefile2
-rw-r--r--package/network/services/dnsmasq/files/dnsmasq.init3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 8c8427f6c1..1710ded5f8 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_UPSTREAM_VERSION:=2.80
PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=10
+PKG_RELEASE:=11
PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
diff --git a/package/network/services/dnsmasq/files/dnsmasq.init b/package/network/services/dnsmasq/files/dnsmasq.init
index 4ae71e438b..93a8f9a108 100644
--- a/package/network/services/dnsmasq/files/dnsmasq.init
+++ b/package/network/services/dnsmasq/files/dnsmasq.init
@@ -860,6 +860,9 @@ dnsmasq_start()
append_parm "$cfg" "tftp_root" "--tftp-root"
append_parm "$cfg" "dhcp_boot" "--dhcp-boot"
append_parm "$cfg" "local_ttl" "--local-ttl"
+ append_parm "$cfg" "max_ttl" "--max-ttl"
+ append_parm "$cfg" "min_cache_ttl" "--min-cache-ttl"
+ append_parm "$cfg" "max_cache_ttl" "--max-cache-ttl"
append_parm "$cfg" "pxe_prompt" "--pxe-prompt"
config_list_foreach "$cfg" "pxe_service" append_pxe_service
config_get DOMAIN "$cfg" domain