aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2022-05-04 21:50:41 +0200
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2022-11-06 19:47:13 +0000
commit7cdf74e163d8da8bf143c1ddd128f636e8e5afde (patch)
treefba2c017e74a3f889c0693c6ba8d2b8e062a7aa2 /package/network/services/dnsmasq/Makefile
parentbf27d977f037794e6f26a87bc3d65d1690721e64 (diff)
downloadupstream-7cdf74e163d8da8bf143c1ddd128f636e8e5afde.tar.gz
upstream-7cdf74e163d8da8bf143c1ddd128f636e8e5afde.tar.bz2
upstream-7cdf74e163d8da8bf143c1ddd128f636e8e5afde.zip
dnsmasq: add uci-defaults script for ipset migration
When running sysupgrade from an existing configuration, move existing ipset definitions to a dedicated config section. Later on, it will allow to serve ipset as well as nftable sets from the same configuration. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/network/services/dnsmasq/Makefile')
-rw-r--r--package/network/services/dnsmasq/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 2a2d4fae79..e2902ed875 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -182,6 +182,7 @@ define Package/dnsmasq/install
$(INSTALL_DATA) ./files/dnsmasq_acl.json $(1)/usr/share/acl.d/
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) ./files/50-dnsmasq-migrate-resolv-conf-auto.sh $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/50-dnsmasq-migrate-ipset.sh $(1)/etc/uci-defaults
endef
Package/dnsmasq-dhcpv6/install = $(Package/dnsmasq/install)