aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-12-21 13:31:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-12-21 13:31:28 +0000
commitefce764f0e60fa9602ac12039371cdad7e3e7237 (patch)
tree1055c709abeeab8b3543b66b6f764a71b1b61bb5 /package/network/services/dnsmasq/Makefile
parent72f00c8de440ac3bf3c373c107e7555182f9fafb (diff)
downloadupstream-efce764f0e60fa9602ac12039371cdad7e3e7237.tar.gz
upstream-efce764f0e60fa9602ac12039371cdad7e3e7237.tar.bz2
upstream-efce764f0e60fa9602ac12039371cdad7e3e7237.zip
dnsmasq: rework init procedure
- cache udhcp check results to speed up subsequent reloads - enable procd file tracking for /var/etc/dnsmasq.conf to only reload service if needed - implement reload action to only restart dnsmasq if /var/etc/dnsmasq.conf actually changed - launch dnsmasq from interface hotplug to avoid race conditions with network bringup Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 39152
Diffstat (limited to 'package/network/services/dnsmasq/Makefile')
-rw-r--r--package/network/services/dnsmasq/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 02712bdc7d..06734651e2 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -83,6 +83,8 @@ define Package/dnsmasq/install
$(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/dnsmasq.hotplug $(1)/etc/hotplug.d/iface/25-dnsmasq
endef
Package/dnsmasq-dhcpv6/install = $(Package/dnsmasq/install)