aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-12-21 13:31:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-12-21 13:31:28 +0000
commitda833133d30c2e8833b22c44d558055e9fcc7568 (patch)
treec5e026bfc357903d28976a06366558b2a696f00f /package/network/services/dnsmasq/Makefile
parent2f536bc64e1e90d22170ca8d4d001820aefbebc1 (diff)
downloadupstream-da833133d30c2e8833b22c44d558055e9fcc7568.tar.gz
upstream-da833133d30c2e8833b22c44d558055e9fcc7568.tar.bz2
upstream-da833133d30c2e8833b22c44d558055e9fcc7568.zip
dnsmasq: rework init procedure
- cache udhcp check results to speed up subsequent reloads - enable procd file tracking for /var/etc/dnsmasq.conf to only reload service if needed - implement reload action to only restart dnsmasq if /var/etc/dnsmasq.conf actually changed - launch dnsmasq from interface hotplug to avoid race conditions with network bringup Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39152 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/dnsmasq/Makefile')
-rw-r--r--package/network/services/dnsmasq/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 02712bdc7d..06734651e2 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -83,6 +83,8 @@ define Package/dnsmasq/install
$(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/dnsmasq.hotplug $(1)/etc/hotplug.d/iface/25-dnsmasq
endef
Package/dnsmasq-dhcpv6/install = $(Package/dnsmasq/install)