aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/Makefile
diff options
context:
space:
mode:
authorHenrique de Moraes Holschuh <henrique@nic.br>2018-08-27 08:31:29 -0300
committerHans Dedecker <dedeckeh@gmail.com>2018-09-06 17:57:59 +0200
commitca1b347691cb963d5b148f238f60f12af305414c (patch)
tree3a08d4f94d14c4522ad3e6a1fdb6a53235b87e39 /package/network/services/dnsmasq/Makefile
parent3d377f4375c6e4a66c6741bbd2549ad53ef671b3 (diff)
downloadupstream-ca1b347691cb963d5b148f238f60f12af305414c.tar.gz
upstream-ca1b347691cb963d5b148f238f60f12af305414c.tar.bz2
upstream-ca1b347691cb963d5b148f238f60f12af305414c.zip
dnsmasq: allow dnsmasq variants to be included in image
The dnsmasq variants should provide dnsmasq, otherwise it is impossible to include them in the image. This change allows one to have CONFIG_PACKAGE_dnsmasq=m and CONFIG_PACKAGE_dnsmasq-full=y, e.g. because you want DNSSEC support, or IPSETs suport on your 3000-devices fleet ;-) Signed-off-by: Henrique de Moraes Holschuh <henrique@nic.br>
Diffstat (limited to 'package/network/services/dnsmasq/Makefile')
-rw-r--r--package/network/services/dnsmasq/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 39889639a5..68fd653699 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -53,6 +53,7 @@ $(call Package/dnsmasq/Default)
TITLE += (with DHCPv6 support)
DEPENDS+=@IPV6
VARIANT:=dhcpv6
+ PROVIDES:=dnsmasq
endef
define Package/dnsmasq-full
@@ -62,6 +63,7 @@ $(call Package/dnsmasq/Default)
+PACKAGE_dnsmasq_full_ipset:kmod-ipt-ipset \
+PACKAGE_dnsmasq_full_conntrack:libnetfilter-conntrack
VARIANT:=full
+ PROVIDES:=dnsmasq
endef
define Package/dnsmasq/description