aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-10-27 21:17:39 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-11-08 23:57:51 +0100
commit6596c95eca50ccdb3fa8098312b82cef59e40434 (patch)
tree628dffeb80eb08964cb18872d09af4e4f65c100f /package/network/services/dnsmasq/Makefile
parenta43a40c49ed21bb3192575deb7a3701eabd9ff4b (diff)
downloadupstream-6596c95eca50ccdb3fa8098312b82cef59e40434.tar.gz
upstream-6596c95eca50ccdb3fa8098312b82cef59e40434.tar.bz2
upstream-6596c95eca50ccdb3fa8098312b82cef59e40434.zip
dnsmasq: Activate LTO
This decreases the binary size when PIE ASLR is activated by 8% on MIPS BE. old: 202,020 /usr/sbin/dnsmasq new: 185,676 /usr/sbin/dnsmasq Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network/services/dnsmasq/Makefile')
-rw-r--r--package/network/services/dnsmasq/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index dc20ada292..a1b51896a9 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -126,8 +126,8 @@ endef
Package/dnsmasq-dhcpv6/conffiles = $(Package/dnsmasq/conffiles)
Package/dnsmasq-full/conffiles = $(Package/dnsmasq/conffiles)
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto=jobserver
COPTS = -DHAVE_UBUS \
$(if $(CONFIG_IPV6),,-DNO_IPV6)