aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2020-01-06 16:21:25 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2020-01-06 17:44:22 +0100
commit414d0541381d432e69190f394dfe2a6e8122d6bb (patch)
treed08fe2fe013d82436fb8ba66ab805c79b27b05be /package/network/services/dnsmasq/Makefile
parent99dd2709b855baa9e68c7c7106743a7c4a91ee0c (diff)
downloadupstream-414d0541381d432e69190f394dfe2a6e8122d6bb.tar.gz
upstream-414d0541381d432e69190f394dfe2a6e8122d6bb.tar.bz2
upstream-414d0541381d432e69190f394dfe2a6e8122d6bb.zip
dnsmasq: Fix potential dnsmasq crash with TCP
This is a backport from the dnsmasq master which should fix a bug which could cause a crash in dnsmasq. I saw the following crashes in my log: [522413.117215] do_page_fault(): sending SIGSEGV to dnsmasq for invalid read access from 2a001450 [522413.124464] epc = 004197f1 in dnsmasq[400000+23000] [522413.129459] ra = 004197ef in dnsmasq[400000+23000] This is happening in blockdata_write() when block->next is dereferenced, but I am not sure if this is related to this problem or if this is a different problem. I am unable to reproduce this problem. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/network/services/dnsmasq/Makefile')
-rw-r--r--package/network/services/dnsmasq/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index c57a837e9e..f3d9a2e07e 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_UPSTREAM_VERSION:=2.80
PKG_VERSION:=$(subst test,~~test,$(subst rc,~rc,$(PKG_UPSTREAM_VERSION)))
-PKG_RELEASE:=15
+PKG_RELEASE:=16
PKG_SOURCE:=$(PKG_NAME)-$(PKG_UPSTREAM_VERSION).tar.xz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq