aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/dnsmasq/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-06-18 10:04:34 +0000
committerSteven Barth <steven@midlink.org>2014-06-18 10:04:34 +0000
commit3d5f483474686c5bb8bfb3f19b55bb5f76b1353c (patch)
tree94564f171306a035efa34f637abf3bc0fed70e13 /package/network/services/dnsmasq/Makefile
parent15646b2175818ceb55b73f7def29737b37580f70 (diff)
downloadupstream-3d5f483474686c5bb8bfb3f19b55bb5f76b1353c.tar.gz
upstream-3d5f483474686c5bb8bfb3f19b55bb5f76b1353c.tar.bz2
upstream-3d5f483474686c5bb8bfb3f19b55bb5f76b1353c.zip
dnsmasq: various house-keeping updates
* Add Authoritative DNS and IPSET to full variant * Remove some bloat from IPSET support * Reintroduce "DHCP no address warning"-patch Signed-off-by: Steven Barth <steven@midlink.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41246 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/dnsmasq/Makefile')
-rw-r--r--package/network/services/dnsmasq/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/network/services/dnsmasq/Makefile b/package/network/services/dnsmasq/Makefile
index 34d543f151..5c54d855c1 100644
--- a/package/network/services/dnsmasq/Makefile
+++ b/package/network/services/dnsmasq/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
PKG_VERSION:=2.71
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
@@ -28,7 +28,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/dnsmasq/Default
SECTION:=net
CATEGORY:=Base system
- TITLE:=A lightweight DNS and DHCP server
+ TITLE:=DNS and DHCP server
URL:=http://www.thekelleys.org.uk/dnsmasq/
endef
@@ -46,7 +46,7 @@ endef
define Package/dnsmasq-full
$(call Package/dnsmasq/Default)
- TITLE += (with DHCPv6 and DNSSEC)
+ TITLE += (with DNSSEC, DHCPv6, Auth DNS, IPSET)
DEPENDS:=@IPV6 +kmod-ipv6 +libnettle
VARIANT:=full
endef
@@ -64,7 +64,7 @@ endef
define Package/dnsmasq-full/description
$(call Package/dnsmasq/description)
-This is a variant with DHCPv6 and DNSSEC support
+This is a variant with DHCPv6, DNSSEC, Authroitative DNS and IPSET support
endef
define Package/dnsmasq/conffiles
@@ -78,7 +78,7 @@ Package/dnsmasq-full/conffiles = $(Package/dnsmasq/conffiles)
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
-COPTS = $(if $(CONFIG_IPV6),,-DNO_IPV6) -DNO_IPSET -DNO_AUTH
+COPTS = $(if $(CONFIG_IPV6),,-DNO_IPV6)
ifeq ($(BUILD_VARIANT),nodhcpv6)
COPTS += -DNO_DHCP6
@@ -87,6 +87,8 @@ endif
ifeq ($(BUILD_VARIANT),full)
COPTS += -DHAVE_DNSSEC
COPTS += $(if $(CONFIG_LIBNETTLE_MINI),-DNO_GMP,)
+else
+ COPTS += -DNO_AUTH -DNO_IPSET
endif
MAKE_FLAGS := \