aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-03 08:01:08 +0000
committerJohn Crispin <john@openwrt.org>2014-11-03 08:01:08 +0000
commitc10d97484a43375a0446dafc8cb4072e26502f37 (patch)
tree9a871898dd0dbf9e198388067465019e8577ccaf /package/network/ipv6
parente2d82442b7261014bf352a57ee76bee2df0d14de (diff)
downloadupstream-c10d97484a43375a0446dafc8cb4072e26502f37.tar.gz
upstream-c10d97484a43375a0446dafc8cb4072e26502f37.tar.bz2
upstream-c10d97484a43375a0446dafc8cb4072e26502f37.zip
Add more license tags with SPDX identifiers
Note, that licensing stuff is a nightmare: many packages does not clearly state their licenses, and often multiple source files are simply copied together - each with different licensing information in the file headers. I tried hard to ensure, that the license information extracted into the OpenWRT's makefiles fit the "spirit" of the packages, e.g. such small packages which come without a dedicated source archive "inherites" the OpenWRT's own license in my opinion. However, I can not garantee that I always picked the correct information and/or did not miss license information. Signed-off-by: Michael Heimpold <mhei@heimpold.de> SVN-Revision: 43155
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/6in4/Makefile3
-rw-r--r--package/network/ipv6/6rd/Makefile3
-rw-r--r--package/network/ipv6/6to4/Makefile3
-rw-r--r--package/network/ipv6/ds-lite/Makefile3
-rw-r--r--package/network/ipv6/map/Makefile3
-rw-r--r--package/network/ipv6/odhcp6c/Makefile3
-rw-r--r--package/network/ipv6/thc-ipv6/Makefile3
7 files changed, 21 insertions, 0 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index aeb187cb58..b5e157962d 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -12,6 +12,9 @@ PKG_VERSION:=18
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
define Package/6in4
diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index 82195c8c3b..b4e796a052 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -12,6 +12,9 @@ PKG_VERSION:=7
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0+
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
define Package/6rd
diff --git a/package/network/ipv6/6to4/Makefile b/package/network/ipv6/6to4/Makefile
index 6be2cc5770..f9eee0e2fb 100644
--- a/package/network/ipv6/6to4/Makefile
+++ b/package/network/ipv6/6to4/Makefile
@@ -12,6 +12,9 @@ PKG_VERSION:=12
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
define Package/6to4
diff --git a/package/network/ipv6/ds-lite/Makefile b/package/network/ipv6/ds-lite/Makefile
index 4a3d1b38cd..c39881bf8b 100644
--- a/package/network/ipv6/ds-lite/Makefile
+++ b/package/network/ipv6/ds-lite/Makefile
@@ -12,6 +12,9 @@ PKG_VERSION:=4
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
define Package/ds-lite
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index 382fe0a8ba..a06a324c01 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -12,6 +12,9 @@ PKG_VERSION:=2
PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 56ed206c3f..c06e68e07b 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -19,6 +19,9 @@ PKG_SOURCE_VERSION:=940e2141ab13727af6323c4d30002f785e466318
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
diff --git a/package/network/ipv6/thc-ipv6/Makefile b/package/network/ipv6/thc-ipv6/Makefile
index 4c75f1869b..255988d81b 100644
--- a/package/network/ipv6/thc-ipv6/Makefile
+++ b/package/network/ipv6/thc-ipv6/Makefile
@@ -18,6 +18,9 @@ PKG_MD5SUM:=5c9be9ad38ac15c368bb5140d031c051
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=GPL-3.0+
+PKG_LICENSE_FILES:=LICENSE
+
include $(INCLUDE_DIR)/package.mk
THC_APPLETS := \