aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2018-09-17 17:53:34 +0200
committerJo-Philipp Wich <jo@mein.io>2018-12-18 11:28:13 +0100
commit6f50d5ccf378d231ca25e06b43cf179d9b07c7cd (patch)
tree43c4ed4fad603027915623ab0fb1efd96d1ebc0b /package/network/ipv6
parentf6eab3c3de026799d98391c7f2729b6779c5a9a9 (diff)
downloadupstream-6f50d5ccf378d231ca25e06b43cf179d9b07c7cd.tar.gz
upstream-6f50d5ccf378d231ca25e06b43cf179d9b07c7cd.tar.bz2
upstream-6f50d5ccf378d231ca25e06b43cf179d9b07c7cd.zip
map: drop default encaplimit value
Setting encaplimit to a numerical value results into the value being included as tunnel encapsulation limit in the destination option header for tunneled packets. Several users have reported interop issues as not all ISPs support the destination option header containing the tunnel encapsulation limit resulting into broken map connectivity. Therefore drop the default encaplimit value for map tunnels so no destination option header is included by default. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com> (backported from d9691b66e2781a43cd4f508605dcfe88c4bbd042)
Diffstat (limited to 'package/network/ipv6')
-rw-r--r--package/network/ipv6/map/Makefile2
-rwxr-xr-xpackage/network/ipv6/map/files/map.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/ipv6/map/Makefile b/package/network/ipv6/map/Makefile
index cfb7c4ac35..10dbe97b48 100644
--- a/package/network/ipv6/map/Makefile
+++ b/package/network/ipv6/map/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=map
PKG_VERSION:=4
-PKG_RELEASE:=11
+PKG_RELEASE:=12
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/map/files/map.sh b/package/network/ipv6/map/files/map.sh
index 5f4add36eb..70dc72326c 100755
--- a/package/network/ipv6/map/files/map.sh
+++ b/package/network/ipv6/map/files/map.sh
@@ -85,7 +85,7 @@ proto_map_setup() {
json_add_string remote $(eval "echo \$RULE_${k}_BR")
json_add_string link $(eval "echo \$RULE_${k}_PD6IFACE")
json_add_object "data"
- json_add_string encaplimit "${encaplimit:-4}"
+ [ -n "$encaplimit" ] && json_add_string encaplimit "$encaplimit"
if [ "$type" = "map-e" ]; then
json_add_array "fmrs"
for i in $(seq $RULE_COUNT); do