aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/odhcp6c/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2013-01-13 17:35:09 +0000
committerSteven Barth <steven@midlink.org>2013-01-13 17:35:09 +0000
commit24df9aecc1a3e05fcbf01f2e113ad9ddc90ed7e6 (patch)
tree5c99b6e5000c8a7a959a364b49e51583ae573443 /package/network/ipv6/odhcp6c/Makefile
parentc5752d0129a1fe61bf3ec588dfc37c5c2e815048 (diff)
downloadupstream-24df9aecc1a3e05fcbf01f2e113ad9ddc90ed7e6.tar.gz
upstream-24df9aecc1a3e05fcbf01f2e113ad9ddc90ed7e6.tar.bz2
upstream-24df9aecc1a3e05fcbf01f2e113ad9ddc90ed7e6.zip
odhcp6c: Add preliminary proto-handler
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35135 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6/odhcp6c/Makefile')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 636b98731e..f97e6ac2ac 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-01-02
+PKG_VERSION:=2013-01-11
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -31,6 +31,9 @@ endef
define Package/odhcp6c/install
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/odhcp6c $(1)/usr/sbin/
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/dhcpv6.sh $(1)/lib/netifd/proto/dhcpv6.sh
+ $(INSTALL_BIN) ./files/dhcpv6.script $(1)/lib/netifd/
endef
$(eval $(call BuildPackage,odhcp6c))