aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/6rd
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2014-03-26 10:12:49 +0000
committerSteven Barth <steven@midlink.org>2014-03-26 10:12:49 +0000
commit58ca40c218871497e81d4cffacea10bef2c265bf (patch)
tree5d0ebda34fd6e711497d03a74fce42003345ed32 /package/network/ipv6/6rd
parent3e85c08bbb6bd627bc8edf5f45aa3fcc4d1c8081 (diff)
downloadupstream-58ca40c218871497e81d4cffacea10bef2c265bf.tar.gz
upstream-58ca40c218871497e81d4cffacea10bef2c265bf.tar.bz2
upstream-58ca40c218871497e81d4cffacea10bef2c265bf.zip
6rd / ds-lite: make the firewall-zones of nested-protocols configurable
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40020 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/ipv6/6rd')
-rw-r--r--package/network/ipv6/6rd/Makefile2
-rw-r--r--package/network/ipv6/6rd/files/6rd.sh9
2 files changed, 8 insertions, 3 deletions
diff --git a/package/network/ipv6/6rd/Makefile b/package/network/ipv6/6rd/Makefile
index 5a4807805c..19177f1c46 100644
--- a/package/network/ipv6/6rd/Makefile
+++ b/package/network/ipv6/6rd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6rd
-PKG_VERSION:=5
+PKG_VERSION:=6
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6rd/files/6rd.sh b/package/network/ipv6/6rd/files/6rd.sh
index e80729c341..58b16c8ff7 100644
--- a/package/network/ipv6/6rd/files/6rd.sh
+++ b/package/network/ipv6/6rd/files/6rd.sh
@@ -14,8 +14,8 @@ proto_6rd_setup() {
local iface="$2"
local link="6rd-$cfg"
- local mtu df ttl ipaddr peeraddr ip6prefix ip6prefixlen ip4prefixlen tunlink sourcerouting
- json_get_vars mtu df ttl ipaddr peeraddr ip6prefix ip6prefixlen ip4prefixlen tunlink sourcerouting
+ local mtu df ttl ipaddr peeraddr ip6prefix ip6prefixlen ip4prefixlen tunlink sourcerouting zone
+ json_get_vars mtu df ttl ipaddr peeraddr ip6prefix ip6prefixlen ip4prefixlen tunlink sourcerouting zone
[ -z "$ip6prefix" -o -z "$peeraddr" ] && {
proto_notify_error "$cfg" "MISSING_ADDRESS"
@@ -68,6 +68,10 @@ proto_6rd_setup() {
[ -n "$tunlink" ] && json_add_string link "$tunlink"
proto_close_tunnel
+ proto_add_data
+ [ -n "$zone" ] && json_add_string zone "$zone"
+ proto_close_data
+
proto_send_update "$cfg"
}
@@ -89,6 +93,7 @@ proto_6rd_init_config() {
proto_config_add_string "ip4prefixlen"
proto_config_add_string "tunlink"
proto_config_add_boolean "sourcerouting"
+ proto_config_add_string "zone"
}
[ -n "$INCLUDE_ONLY" ] || {