aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/6in4
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-01-30 09:05:53 +0000
committerSteven Barth <cyrus@openwrt.org>2013-01-30 09:05:53 +0000
commita0a91963af6b96dc648ad4fe56ce4415ccb74cbd (patch)
tree93e1a553bb88dc2163217def5835742007373dfa /package/network/ipv6/6in4
parentce8b22604623f44b85c8335627accbb5e40145b5 (diff)
downloadupstream-a0a91963af6b96dc648ad4fe56ce4415ccb74cbd.tar.gz
upstream-a0a91963af6b96dc648ad4fe56ce4415ccb74cbd.tar.bz2
upstream-a0a91963af6b96dc648ad4fe56ce4415ccb74cbd.zip
6in4: work around hanging wget process
SVN-Revision: 35408
Diffstat (limited to 'package/network/ipv6/6in4')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh6
2 files changed, 5 insertions, 3 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index cddf0372e5..7090234358 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=13
+PKG_VERSION:=14
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index ef25322346..e27e86ef08 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -65,8 +65,10 @@ proto_6in4_setup() {
local max=3
while [ $((++try)) -le $max ]; do
- wget -qO/dev/null "$url" 2>/dev/null && break
- sleep 1
+ ( wget -qO/dev/null "$url" 2>/dev/null ) &
+ local pid=$!
+ ( sleep 5; kill $pid 2>/dev/null ) &
+ wait $pid && break
done
}
}