aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/6in4
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-05-19 07:53:08 +0000
committerSteven Barth <cyrus@openwrt.org>2015-05-19 07:53:08 +0000
commit08f057c703fca370fd2f212eef6e0122028be023 (patch)
treeab36479b9a4bbdc9245af4dcfd80acbac2771c98 /package/network/ipv6/6in4
parent12969569086d18bd6ee4235224ea098607e860b9 (diff)
downloadupstream-08f057c703fca370fd2f212eef6e0122028be023.tar.gz
upstream-08f057c703fca370fd2f212eef6e0122028be023.tar.bz2
upstream-08f057c703fca370fd2f212eef6e0122028be023.zip
ipv6: remove now unneeded source-dest-routing workarounds
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 45700
Diffstat (limited to 'package/network/ipv6/6in4')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh13
2 files changed, 5 insertions, 10 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index 21e69e6f49..b7c2da725c 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
PKG_VERSION:=21
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 0289df3031..af2ddca1d7 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -27,8 +27,8 @@ proto_6in4_setup() {
local iface="$2"
local link="6in4-$cfg"
- local mtu ttl tos ipaddr peeraddr ip6addr ip6prefix tunnelid username password updatekey sourcerouting
- json_get_vars mtu ttl tos ipaddr peeraddr ip6addr ip6prefix tunnelid username password updatekey sourcerouting
+ local mtu ttl tos ipaddr peeraddr ip6addr ip6prefix tunnelid username password updatekey
+ json_get_vars mtu ttl tos ipaddr peeraddr ip6addr ip6prefix tunnelid username password updatekey
[ -z "$peeraddr" ] && {
proto_notify_error "$cfg" "MISSING_ADDRESS"
@@ -48,21 +48,17 @@ proto_6in4_setup() {
proto_init_update "$link" 1
- local source=""
- [ "$sourcerouting" != "0" ] && source="::/128"
- proto_add_ipv6_route "::" 0 "" "" "" "$source"
-
[ -n "$ip6addr" ] && {
local local6="${ip6addr%%/*}"
local mask6="${ip6addr##*/}"
[[ "$local6" = "$mask6" ]] && mask6=
proto_add_ipv6_address "$local6" "$mask6"
- [ "$sourcerouting" != "0" ] && proto_add_ipv6_route "::" 0 "" "" "" "$local6/$mask6"
+ proto_add_ipv6_route "::" 0 "" "" "" "$local6/$mask6"
}
[ -n "$ip6prefix" ] && {
proto_add_ipv6_prefix "$ip6prefix"
- [ "$sourcerouting" != "0" ] && proto_add_ipv6_route "::" 0 "" "" "" "$ip6prefix"
+ proto_add_ipv6_route "::" 0 "" "" "" "$ip6prefix"
}
proto_add_tunnel
@@ -146,7 +142,6 @@ proto_6in4_init_config() {
proto_config_add_int "mtu"
proto_config_add_int "ttl"
proto_config_add_string "tos"
- proto_config_add_boolean "sourcerouting"
}
[ -n "$INCLUDE_ONLY" ] || {