aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/6in4
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2014-10-30 13:15:18 +0000
committerSteven Barth <cyrus@openwrt.org>2014-10-30 13:15:18 +0000
commit8f877ff42b88ec798af3237569b33907dada01e8 (patch)
tree83ff515bf24f843c4da93d479a71d2fe3f7d77a5 /package/network/ipv6/6in4
parent6a4a437e0421a4b4beb38248c693b3fd321ef414 (diff)
downloadupstream-8f877ff42b88ec798af3237569b33907dada01e8.tar.gz
upstream-8f877ff42b88ec798af3237569b33907dada01e8.tar.bz2
upstream-8f877ff42b88ec798af3237569b33907dada01e8.zip
6in4: https support for he.net tunnel api
HE.net tunnel update API requests are now made via https if an SSL-capable wget is installed. Certificate validation is conditionally enabled if the CA certs are available. Signed-off-by: Andrew Skalski <askalski@gmail.com> SVN-Revision: 43124
Diffstat (limited to 'package/network/ipv6/6in4')
-rw-r--r--package/network/ipv6/6in4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6in4/files/6in4.sh13
2 files changed, 12 insertions, 3 deletions
diff --git a/package/network/ipv6/6in4/Makefile b/package/network/ipv6/6in4/Makefile
index 1235ce5335..5b3669335d 100644
--- a/package/network/ipv6/6in4/Makefile
+++ b/package/network/ipv6/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=17
+PKG_VERSION:=18
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6in4/files/6in4.sh b/package/network/ipv6/6in4/files/6in4.sh
index 714d629416..7ffd40dc06 100755
--- a/package/network/ipv6/6in4/files/6in4.sh
+++ b/package/network/ipv6/6in4/files/6in4.sh
@@ -66,12 +66,21 @@ proto_6in4_setup() {
[ -n "$tunnelid" -a -n "$username" -a \( -n "$password" -o -n "$updatekey" \) ] && {
[ -n "$updatekey" ] && password="$updatekey"
- local url="http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
+ local http="http"
+ local wget_opts="-qO/dev/null"
+ if wget --version | grep -qF "+https"; then
+ http="https"
+ [ -z "$(find ${SSL_CERT_DIR-/etc/ssl/certs} -name "*.0" 2>/dev/null)" ] && {
+ wget_opts="$wget_opts --no-check-certificate"
+ }
+ fi
+
+ local url="$http://ipv4.tunnelbroker.net/nic/update?username=$username&password=$password&hostname=$tunnelid"
local try=0
local max=3
while [ $((++try)) -le $max ]; do
- ( exec wget -qO/dev/null "$url" 2>/dev/null ) &
+ ( exec wget $wget_opts "$url" 2>/dev/null ) &
local pid=$!
( sleep 5; kill $pid 2>/dev/null ) &
wait $pid && break