aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-17 21:08:40 +0800
committerPaul Spooren <mail@aparcar.org>2023-05-18 11:35:29 +0200
commit48ed07bc0b94b930d369baf911014bedd5bf6a7e (patch)
treea9b4a50b621a0212b349e73140e8066cf94476d5 /package/network/config
parent3a6657540c3d6fc50a63caf8432e301e825ada16 (diff)
downloadupstream-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.gz
upstream-48ed07bc0b94b930d369baf911014bedd5bf6a7e.tar.bz2
upstream-48ed07bc0b94b930d369baf911014bedd5bf6a7e.zip
treewide: replace AUTORELEASE with real PKG_RELEASE
Based on Paul Fertser <fercerpav@gmail.com>'s guidance: Change AUTORELEASE in rules.mk to: ``` AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile)) ``` then update all affected packages by: ``` for i in $(git grep -l PKG_RELEASE:=.*AUTORELEASE | sed 's^.*/\([^/]*\)/Makefile^\1^';); do make package/$i/clean done ``` Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/firewall4/Makefile2
-rw-r--r--package/network/config/ltq-vdsl-vr9-app/Makefile2
-rw-r--r--package/network/config/qos-scripts/Makefile2
-rw-r--r--package/network/config/qosify/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/package/network/config/firewall4/Makefile b/package/network/config/firewall4/Makefile
index 687d3c8c68..809f3d3f04 100644
--- a/package/network/config/firewall4/Makefile
+++ b/package/network/config/firewall4/Makefile
@@ -5,7 +5,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall4
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall4.git
diff --git a/package/network/config/ltq-vdsl-vr9-app/Makefile b/package/network/config/ltq-vdsl-vr9-app/Makefile
index 85d332e5b1..c51489e2c5 100644
--- a/package/network/config/ltq-vdsl-vr9-app/Makefile
+++ b/package/network/config/ltq-vdsl-vr9-app/Makefile
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-vr9-app
PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=5
PKG_BASE_NAME:=dsl_cpe_control
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@OPENWRT
diff --git a/package/network/config/qos-scripts/Makefile b/package/network/config/qos-scripts/Makefile
index d6e7df1467..774ce4d94a 100644
--- a/package/network/config/qos-scripts/Makefile
+++ b/package/network/config/qos-scripts/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=qos-scripts
PKG_VERSION:=1.3.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=33
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
diff --git a/package/network/config/qosify/Makefile b/package/network/config/qosify/Makefile
index ccfa3ff3b3..f4ad042235 100644
--- a/package/network/config/qosify/Makefile
+++ b/package/network/config/qosify/Makefile
@@ -14,7 +14,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_DATE:=2023-03-07
PKG_SOURCE_VERSION:=9a47ea4b683dd845ec94534fcd82d3117c9ab313
PKG_MIRROR_HASH:=c4c313aed4a405492201612bdfef5e219c9a994a35f35acc84fc8327d9aa73d2
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=1
PKG_LICENSE:=GPL-2.0
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>