aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2021-10-19 00:42:02 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2022-01-06 14:54:50 +0200
commit53b87a7a28525a634577f9215e2bb9170cf14dfb (patch)
tree73903d2111ee0fd1cf0af8c38201ec64aaaaabbe /package/network/config
parent3ec25a657d527427d401562697d6be9b8f375132 (diff)
downloadupstream-53b87a7a28525a634577f9215e2bb9170cf14dfb.tar.gz
upstream-53b87a7a28525a634577f9215e2bb9170cf14dfb.tar.bz2
upstream-53b87a7a28525a634577f9215e2bb9170cf14dfb.zip
firewall/firewall4: provide uci-firewall
Provide uci-firewall via PROVIDES in both firewall and firewall4. This will allow us to change the dependency of luci-app-firewall to uci-firewall, making it possible to use it with either implementation. Move CONFLICTS from firewall4 to firewall, to solve this recursive dependency problem: tmp/.config-package.in:307:error: recursive dependency detected! tmp/.config-package.in:307: symbol PACKAGE_firewall is selected by PACKAGE_firewall4 tmp/.config-package.in:328: symbol PACKAGE_firewall4 depends on PACKAGE_firewall Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> Reviewed-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/firewall/Makefile4
-rw-r--r--package/network/config/firewall4/Makefile2
2 files changed, 4 insertions, 2 deletions
diff --git a/package/network/config/firewall/Makefile b/package/network/config/firewall/Makefile
index 378a912f9d..815e33604c 100644
--- a/package/network/config/firewall/Makefile
+++ b/package/network/config/firewall/Makefile
@@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
@@ -29,6 +29,8 @@ define Package/firewall
CATEGORY:=Base system
TITLE:=OpenWrt C Firewall
DEPENDS:=+libubox +libubus +libuci +libip4tc +IPV6:libip6tc +libxtables +kmod-ipt-core +kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +kmod-ipt-nat
+ PROVIDES:=uci-firewall
+ CONFLICTS:=firewall4
endef
define Package/firewall/description
diff --git a/package/network/config/firewall4/Makefile b/package/network/config/firewall4/Makefile
index c95a15a839..d7f8334dfc 100644
--- a/package/network/config/firewall4/Makefile
+++ b/package/network/config/firewall4/Makefile
@@ -26,7 +26,7 @@ define Package/firewall4
+kmod-nft-nat +kmod-nft-nat6 \
+nftables-json \
+ucode +ucode-mod-fs +ucode-mod-ubus +ucode-mod-uci
- CONFLICTS:=firewall
+ PROVIDES:=uci-firewall
endef
define Package/firewall4/description