aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-08-03 21:11:57 +0200
committerMathias Kresin <dev@kresin.me>2017-08-06 09:22:03 +0200
commita94555ce2454f69845bfc194245dbf0e71704cb3 (patch)
tree6f3d2eaeb0ae4bf73d745354a967a34dbba68032 /package/network/config
parente5e6045130ded7d3ae2dc579b0a8cca6f41aca90 (diff)
downloadupstream-a94555ce2454f69845bfc194245dbf0e71704cb3.tar.gz
upstream-a94555ce2454f69845bfc194245dbf0e71704cb3.tar.bz2
upstream-a94555ce2454f69845bfc194245dbf0e71704cb3.zip
ltq-xdsl-app: drop esi call
The esi call was added to workaround a race condition between applying a configured mac address to the wan interface and starting the protocol (handler) as it was observed in a DHCP over ATM bridge configuration. Martin Schiller, TDT GmbH was so kind to test with their local infrastructure if the race condition still exists. The provided package dumps captured behind the DSLAM shows that it doesn't. It was most likely fixed with adding carrier support to the lantiq ptm/atm driver. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/ltq-adsl-app/files/dsl_control2
-rw-r--r--package/network/config/ltq-vdsl-app/Makefile2
-rw-r--r--package/network/config/ltq-vdsl-app/files/vdsl_cpe_control_wrapper1
3 files changed, 1 insertions, 4 deletions
diff --git a/package/network/config/ltq-adsl-app/files/dsl_control b/package/network/config/ltq-adsl-app/files/dsl_control
index dcde6b2338..8218186ef8 100644
--- a/package/network/config/ltq-adsl-app/files/dsl_control
+++ b/package/network/config/ltq-adsl-app/files/dsl_control
@@ -45,8 +45,6 @@ start() {
return 1
}
- esi $(printf '%012X' $((1+0x$(tr -d : </sys/class/net/eth0/address))))
-
service_start /sbin/dsl_cpe_control -i${xtu} \
-n /sbin/dsl_notify.sh \
-f ${firmware}
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index 1ddb83a0af..815f89c0b8 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -28,7 +28,7 @@ define Package/ltq-vdsl-app
CATEGORY:=Network
TITLE:=Lantiq VDSL userland tool
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt +atm-esi
+ DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt
endef
define Package/ltq-vdsl-app/description
diff --git a/package/network/config/ltq-vdsl-app/files/vdsl_cpe_control_wrapper b/package/network/config/ltq-vdsl-app/files/vdsl_cpe_control_wrapper
index cc127f7779..8e7c1cb4b8 100644
--- a/package/network/config/ltq-vdsl-app/files/vdsl_cpe_control_wrapper
+++ b/package/network/config/ltq-vdsl-app/files/vdsl_cpe_control_wrapper
@@ -7,5 +7,4 @@ for mod in $LOAD; do
grep -q "$mod " /proc/modules || insmod "$mod"
done
-esi $(printf '%012X' $((1+0x$(tr -d : </sys/class/net/eth0/address))))
exec /sbin/vdsl_cpe_control "$@"