aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2019-04-13 10:31:44 +0200
committerPetr Štetiar <ynezz@true.cz>2019-05-20 21:19:48 +0200
commit2c26dc7b411e0b3d98bba2751b52878f5c89db5b (patch)
tree502f844535af62f777eb9c9afe9e414e66825935 /package/network/config
parent01c0d7f86f68ec355bb87b755d52c3dcf9fe68bd (diff)
downloadupstream-2c26dc7b411e0b3d98bba2751b52878f5c89db5b.tar.gz
upstream-2c26dc7b411e0b3d98bba2751b52878f5c89db5b.tar.bz2
upstream-2c26dc7b411e0b3d98bba2751b52878f5c89db5b.zip
netifd: add support for the new ar8xxx MIB counters settings
Commit "generic: ar8216: add mib_poll_interval switch attribute" has added mib_poll_interval global config option and commit "generic: ar8216: group MIB counters and use two basic ones only by default" has added mib_type config option. Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'package/network/config')
-rw-r--r--package/network/config/netifd/Makefile2
-rwxr-xr-xpackage/network/config/netifd/files/etc/init.d/network4
2 files changed, 4 insertions, 2 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 8b641ca139..0ea928544a 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
diff --git a/package/network/config/netifd/files/etc/init.d/network b/package/network/config/netifd/files/etc/init.d/network
index 99d9f6582f..2321a309a5 100755
--- a/package/network/config/netifd/files/etc/init.d/network
+++ b/package/network/config/netifd/files/etc/init.d/network
@@ -115,7 +115,9 @@ validate_switch_section()
'name:string' \
'enable:bool' \
'enable_vlan:bool' \
- 'reset:bool'
+ 'reset:bool' \
+ 'ar8xxx_mib_poll_interval:uinteger' \
+ 'ar8xxx_mib_type:range(0,1)'
}
validate_switch_vlan()