aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/qosify/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-11-19 23:50:50 +0100
committerFelix Fietkau <nbd@nbd.name>2021-11-19 23:51:20 +0100
commitb764cb9e5b1040b6dc13773f8cc153ce6cd7c44d (patch)
treef54e7c60db691dfbe1a379dc8514c929812a38a0 /package/network/config/qosify/Makefile
parent991966f1f55d72f0350acf4b0151059a354783ec (diff)
downloadupstream-b764cb9e5b1040b6dc13773f8cc153ce6cd7c44d.tar.gz
upstream-b764cb9e5b1040b6dc13773f8cc153ce6cd7c44d.tar.bz2
upstream-b764cb9e5b1040b6dc13773f8cc153ce6cd7c44d.zip
qosify: add qosify-status script
This will show detailed status for all devices/interfaces Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/config/qosify/Makefile')
-rw-r--r--package/network/config/qosify/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/network/config/qosify/Makefile b/package/network/config/qosify/Makefile
index c5d1ce789b..01c6498e00 100644
--- a/package/network/config/qosify/Makefile
+++ b/package/network/config/qosify/Makefile
@@ -46,7 +46,10 @@ endef
define Package/qosify/install
$(INSTALL_DIR) $(1)/lib/bpf $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config $(1)/etc/hotplug.d/net $(1)/etc/qosify
$(INSTALL_DATA) $(PKG_BUILD_DIR)/qosify-bpf.o $(1)/lib/bpf
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/qosify $(1)/usr/sbin/
+ $(INSTALL_BIN) \
+ $(PKG_INSTALL_DIR)/usr/bin/qosify \
+ ./files/qosify-status \
+ $(1)/usr/sbin/
$(INSTALL_BIN) ./files/qosify.init $(1)/etc/init.d/qosify
$(INSTALL_DATA) ./files/qosify-defaults.conf $(1)/etc/qosify/00-defaults.conf
$(INSTALL_DATA) ./files/qosify.conf $(1)/etc/config/qosify