aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/ltq-vdsl-app/Makefile
diff options
context:
space:
mode:
authorMartin Schiller <ms@dev.tdt.de>2017-08-03 09:44:21 +0200
committerMathias Kresin <dev@kresin.me>2017-08-06 09:22:03 +0200
commitc6504327d1d7a7be65dae781edc6283454601357 (patch)
tree083a356c2db233ae5e6f7dfa561a722cd1591fd1 /package/network/config/ltq-vdsl-app/Makefile
parent2d6c7c2526b6cc522975e27c26cd1d42ebb7bcd1 (diff)
downloadupstream-c6504327d1d7a7be65dae781edc6283454601357.tar.gz
upstream-c6504327d1d7a7be65dae781edc6283454601357.tar.bz2
upstream-c6504327d1d7a7be65dae781edc6283454601357.zip
ltq-vdsl-app: use notification based ATM/PTM driver load
This patch removes the fixed atm/ptm driver loading and switches to notification based driver loading. Signed-off-by: Martin Schiller <ms@dev.tdt.de>
Diffstat (limited to 'package/network/config/ltq-vdsl-app/Makefile')
-rw-r--r--package/network/config/ltq-vdsl-app/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index 815f89c0b8..20b506c48e 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -58,9 +58,10 @@ CONFIGURE_ARGS += \
#CONFIGURE_ARGS += --enable-model=debug
define Package/ltq-vdsl-app/install
- $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin $(1)/etc/hotplug.d/dsl
$(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
- $(INSTALL_BIN) ./files/vdsl_cpe_control_wrapper $(1)/sbin/
+ $(INSTALL_BIN) ./files/10_atm.sh $(1)/etc/hotplug.d/dsl
+ $(INSTALL_BIN) ./files/10_ptm.sh $(1)/etc/hotplug.d/dsl
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
$(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/