aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/ltq-vdsl-app/Makefile
diff options
context:
space:
mode:
authorMartin Schiller <ms@dev.tdt.de>2017-10-09 08:26:01 +0200
committerMathias Kresin <dev@kresin.me>2017-10-15 11:11:29 +0200
commit2dc9c8206b7a452ab6977945206ce9384b2d5f3f (patch)
tree448dc67167a776a609f93b4b70c90c627ce2c11c /package/network/config/ltq-vdsl-app/Makefile
parent08bbb804c88a74cd7a04cea548cebf85bcf09b8f (diff)
downloadupstream-2dc9c8206b7a452ab6977945206ce9384b2d5f3f.tar.gz
upstream-2dc9c8206b7a452ab6977945206ce9384b2d5f3f.tar.bz2
upstream-2dc9c8206b7a452ab6977945206ce9384b2d5f3f.zip
lantiq: xrx200: rename nas0/ptm0 to dsl0
This change makes it possible to configure the wan/dsl ppp interface settings independantly from the used TC-Layer (ATM/PTM). Now you can move a device from an ADSL/ATM port to an VDSL/PTM port without any configuration changes for example. Signed-off-by: Martin Schiller <ms@dev.tdt.de> [use the dsl0 interface name for the default netdev trigger in 01_led, add ip dependency] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/network/config/ltq-vdsl-app/Makefile')
-rw-r--r--package/network/config/ltq-vdsl-app/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/network/config/ltq-vdsl-app/Makefile b/package/network/config/ltq-vdsl-app/Makefile
index 20b506c48e..baf63f9d13 100644
--- a/package/network/config/ltq-vdsl-app/Makefile
+++ b/package/network/config/ltq-vdsl-app/Makefile
@@ -28,7 +28,7 @@ define Package/ltq-vdsl-app
CATEGORY:=Network
TITLE:=Lantiq VDSL userland tool
URL:=http://www.lantiq.com/
- DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt
+ DEPENDS:=@TARGET_lantiq_xrx200 +libpthread +librt +ip
endef
define Package/ltq-vdsl-app/description
@@ -58,10 +58,11 @@ CONFIGURE_ARGS += \
#CONFIGURE_ARGS += --enable-model=debug
define Package/ltq-vdsl-app/install
- $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin $(1)/etc/hotplug.d/dsl
+ $(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin $(1)/etc/hotplug.d/dsl $(1)/etc/hotplug.d/net
$(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
$(INSTALL_BIN) ./files/10_atm.sh $(1)/etc/hotplug.d/dsl
$(INSTALL_BIN) ./files/10_ptm.sh $(1)/etc/hotplug.d/dsl
+ $(INSTALL_BIN) ./files/10-xdsl_rename $(1)/etc/hotplug.d/net
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin/vdsl_cpe_control
$(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/