aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/ltq-adsl-app/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2021-01-26 09:00:49 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2021-02-08 21:43:00 +0100
commit42fc827b119cecea003e2631e92e37bb1b3e9cc1 (patch)
tree4c0e19c662cbb382b4524df0529a126402b9f44a /package/network/config/ltq-adsl-app/Makefile
parent5372205ca9afea8e51c1762eabcaf5a97350bbaf (diff)
downloadupstream-42fc827b119cecea003e2631e92e37bb1b3e9cc1.tar.gz
upstream-42fc827b119cecea003e2631e92e37bb1b3e9cc1.tar.bz2
upstream-42fc827b119cecea003e2631e92e37bb1b3e9cc1.zip
ltq-adsl-app: add ubus support to get metrics
As with ltq-vdsl-app, see previous commit. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/network/config/ltq-adsl-app/Makefile')
-rw-r--r--package/network/config/ltq-adsl-app/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/network/config/ltq-adsl-app/Makefile b/package/network/config/ltq-adsl-app/Makefile
index 38d2ef06a5..0e8bacdbec 100644
--- a/package/network/config/ltq-adsl-app/Makefile
+++ b/package/network/config/ltq-adsl-app/Makefile
@@ -35,7 +35,7 @@ define Package/ltq-adsl-app
CATEGORY:=Network
TITLE:=Lantiq DSL userland tool
URL:=http://www.lantiq.com/
- DEPENDS:=@(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy||TARGET_lantiq_ase) +libpthread +ltq-dsl-base
+ DEPENDS:=@(TARGET_lantiq_xway||TARGET_lantiq_xway_legacy||TARGET_lantiq_ase) +libpthread +ltq-dsl-base +libubox +libubus
MENU:=1
endef
@@ -75,6 +75,11 @@ CONFIGURE_ARGS += \
TARGET_CFLAGS += -I$(LINUX_DIR)/include
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ $(CP) ../ltq-vdsl-app/src/src/dsl_cpe_ubus.c $(PKG_BUILD_DIR)/src/
+endef
+
define Package/ltq-adsl-app/install
$(INSTALL_DIR) $(1)/etc/init.d $(1)/sbin $(1)/etc/hotplug.d/dsl
$(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/