aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall3
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-02-21 22:33:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-02-21 22:33:44 +0000
commit7d7d88b58047d269f6216ceab61c943df1b1a8ca (patch)
tree647bf4c1596a3bdfcd3a03023ab7888c61d9974d /package/network/config/firewall3
parent42cdd3bef4bd16fa2845c979ce3c46daba1db97a (diff)
downloadupstream-7d7d88b58047d269f6216ceab61c943df1b1a8ca.tar.gz
upstream-7d7d88b58047d269f6216ceab61c943df1b1a8ca.tar.bz2
upstream-7d7d88b58047d269f6216ceab61c943df1b1a8ca.zip
firewall3: update to git head
- all uci rules are boxed in custom chains now, so a firewall stop leaves user rules intact - properly handle selective ipv4 or ipv6 only firewall start/stop/restart actions - support ip ranges (e.g. option src_ip '!192.168.1.1-192.168.1.100' -> -m iprange ! --src-range 192.168.1.1-192.168.1.100') - support time options (e.g. option weekdays 'Mon Tue Sat' -> -m time --weekdays 1,2,6') SVN-Revision: 35738
Diffstat (limited to 'package/network/config/firewall3')
-rw-r--r--package/network/config/firewall3/Makefile4
-rwxr-xr-xpackage/network/config/firewall3/files/firewall.init4
2 files changed, 6 insertions, 2 deletions
diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index 063e554677..5282613d65 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall3
-PKG_VERSION:=2013-02-17
+PKG_VERSION:=2013-02-21
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=a32e331a11034403df2e26807df9195435b6fb8a
+PKG_SOURCE_VERSION:=fe3ecee341da8542aa25b962dcb8bcc628fcdd1e
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
diff --git a/package/network/config/firewall3/files/firewall.init b/package/network/config/firewall3/files/firewall.init
index bddbadd880..8c1dbd94ca 100755
--- a/package/network/config/firewall3/files/firewall.init
+++ b/package/network/config/firewall3/files/firewall.init
@@ -15,3 +15,7 @@ start() {
stop() {
fw3 stop
}
+
+restart() {
+ fw3 restart
+}