aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/config/firewall3/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-04-24 14:17:24 +0000
committerSteven Barth <cyrus@openwrt.org>2013-04-24 14:17:24 +0000
commit2c78c1457b2a0f44dd295bbf5fc7c6e6465409a5 (patch)
tree132dfc7d1dee8c95a3069eea91249467594d0bc9 /package/network/config/firewall3/Makefile
parentaf30e5e6bb5dcf1b615ea862fd8bb7b902c7a852 (diff)
downloadupstream-2c78c1457b2a0f44dd295bbf5fc7c6e6465409a5.tar.gz
upstream-2c78c1457b2a0f44dd295bbf5fc7c6e6465409a5.tar.bz2
upstream-2c78c1457b2a0f44dd295bbf5fc7c6e6465409a5.zip
firewall3: Make IPv6 ULA-Border generation dynamic
This fixes working behind another router which gives out ULAs. SVN-Revision: 36416
Diffstat (limited to 'package/network/config/firewall3/Makefile')
-rw-r--r--package/network/config/firewall3/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index 5455f8f08d..0e9053f1e4 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall3
-PKG_VERSION:=2013-03-22
+PKG_VERSION:=2013-04-24
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
@@ -49,6 +49,8 @@ define Package/firewall3/install
$(INSTALL_DATA) ./files/firewall.config $(1)/etc/config/firewall
$(INSTALL_DIR) $(1)/etc/
$(INSTALL_DATA) ./files/firewall.user $(1)/etc/firewall.user
+ $(INSTALL_DIR) $(1)/usr/share/firewall/
+ $(INSTALL_BIN) ./files/ipv6-ula-border.sh $(1)/usr/share/firewall/ipv6-ula-border.sh
endef
$(eval $(call BuildPackage,firewall3))