aboutsummaryrefslogtreecommitdiffstats
path: root/package/mtd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-26 01:03:21 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-26 01:03:21 +0000
commit706bd43332f7db8980c1096fa9d19547dbb86a13 (patch)
tree46eb61d2b869d9c126dca7d6a8b16c41947e9ccc /package/mtd
parent41e1792c3ea45e7c6d7aeea33b896664d5906247 (diff)
downloadupstream-706bd43332f7db8980c1096fa9d19547dbb86a13.tar.gz
upstream-706bd43332f7db8980c1096fa9d19547dbb86a13.tar.bz2
upstream-706bd43332f7db8980c1096fa9d19547dbb86a13.zip
add reboot fix for mtd (thanks, wbx)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5645 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mtd')
-rw-r--r--package/mtd/Makefile2
-rw-r--r--package/mtd/src/mtd.c12
2 files changed, 9 insertions, 5 deletions
diff --git a/package/mtd/Makefile b/package/mtd/Makefile
index 8444bd8029..cf23fbeebc 100644
--- a/package/mtd/Makefile
+++ b/package/mtd/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mtd
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
diff --git a/package/mtd/src/mtd.c b/package/mtd/src/mtd.c
index 80d09abd2a..7d1e36010c 100644
--- a/package/mtd/src/mtd.c
+++ b/package/mtd/src/mtd.c
@@ -28,17 +28,20 @@
#include <stdlib.h>
#include <stdio.h>
#include <stdint.h>
+#include <sys/ioctl.h>
+#include <sys/syscall.h>
#include <fcntl.h>
#include <errno.h>
#include <error.h>
#include <time.h>
+#include <string.h>
#include <sys/ioctl.h>
#include <sys/types.h>
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/stat.h>
#include <sys/reboot.h>
-#include <string.h>
+#include <linux/reboot.h>
#include "mtd.h"
@@ -458,8 +461,9 @@ int main (int argc, char **argv)
sync();
- if (boot)
- kill(1, 15); // send SIGTERM to init for reboot
-
+ if (boot) {
+ fflush(stdout);
+ syscall(SYS_reboot,LINUX_REBOOT_MAGIC1,LINUX_REBOOT_MAGIC2,LINUX_REBOOT_CMD_RESTART,NULL);
+ }
return 0;
}