aboutsummaryrefslogtreecommitdiffstats
path: root/package/mountd
diff options
context:
space:
mode:
authorVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2010-10-16 13:57:55 +0000
committerVasilis Tsiligiannis <b_tsiligiannis@silverton.gr>2010-10-16 13:57:55 +0000
commitf7bac5b01ea282e167341cfc4d4382ff75ae3bb7 (patch)
tree29100b24eed7ebb998cf31bad12b7a884454cdc2 /package/mountd
parent1d0359c6f272a998641436176a0ef018eb5242e7 (diff)
downloadupstream-f7bac5b01ea282e167341cfc4d4382ff75ae3bb7.tar.gz
upstream-f7bac5b01ea282e167341cfc4d4382ff75ae3bb7.tar.bz2
upstream-f7bac5b01ea282e167341cfc4d4382ff75ae3bb7.zip
[package] mountd: Rename uci_add_history to uci_add_delta (#8084)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@23474 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mountd')
-rw-r--r--package/mountd/Makefile2
-rw-r--r--package/mountd/patches/010-uci_rename_history_to_delta.patch27
2 files changed, 28 insertions, 1 deletions
diff --git a/package/mountd/Makefile b/package/mountd/Makefile
index 8cecc15335..f7a68242ac 100644
--- a/package/mountd/Makefile
+++ b/package/mountd/Makefile
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=mountd
PKG_VERSION:=0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
diff --git a/package/mountd/patches/010-uci_rename_history_to_delta.patch b/package/mountd/patches/010-uci_rename_history_to_delta.patch
new file mode 100644
index 0000000000..65b2f84343
--- /dev/null
+++ b/package/mountd/patches/010-uci_rename_history_to_delta.patch
@@ -0,0 +1,27 @@
+---
+ lib/uci.c | 2 +-
+ lib/ucix.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/lib/uci.c
++++ b/lib/uci.c
+@@ -28,7 +28,7 @@ struct uci_package *p = NULL;
+ struct uci_context* uci_init(char *config_file)
+ {
+ struct uci_context *ctx = uci_alloc_context();
+- uci_add_history_path(ctx, "/var/state");
++ uci_add_delta_path(ctx, "/var/state");
+ if(uci_load(ctx, config_file, &p) != UCI_OK)
+ {
+ log_printf("/etc/config/%s is missing or corrupt\n", config_file);
+--- a/lib/ucix.c
++++ b/lib/ucix.c
+@@ -18,7 +18,7 @@ static inline int ucix_get_ptr(struct uc
+ struct uci_context* ucix_init(const char *config_file)
+ {
+ struct uci_context *ctx = uci_alloc_context();
+- uci_add_history_path(ctx, "/var/state");
++ uci_add_delta_path(ctx, "/var/state");
+ if(uci_load(ctx, config_file, NULL) != UCI_OK)
+ {
+ printf("%s/%s is missing or corrupt\n", ctx->savedir, config_file);