aboutsummaryrefslogtreecommitdiffstats
path: root/package/mountd/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <blogic@openwrt.org>2013-06-21 16:54:37 +0000
commitf1b4824c865b228039d84b2605b2e7e4f34cddeb (patch)
tree37c9cbe251e4fb790aaa72e862c35822be30b491 /package/mountd/Makefile
parentd2642de7494bba312bbb22cfeb3ad77130a10047 (diff)
downloadupstream-f1b4824c865b228039d84b2605b2e7e4f34cddeb.tar.gz
upstream-f1b4824c865b228039d84b2605b2e7e4f34cddeb.tar.bz2
upstream-f1b4824c865b228039d84b2605b2e7e4f34cddeb.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37007 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mountd/Makefile')
-rw-r--r--package/mountd/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/package/mountd/Makefile b/package/mountd/Makefile
deleted file mode 100644
index 10534ccdf4..0000000000
--- a/package/mountd/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright (C) 2009-2012 OpenWrt.org
-# All rights reserved.
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mountd
-PKG_VERSION:=0.1
-PKG_RELEASE:=6
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
-PKG_MD5SUM:=b77253ee4321d24d200fffc4f7ca3d15
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/mountd
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=OpenWrt automount daemon
- DEPENDS:=@USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
- URL:=http://www.openwrt.org
-endef
-
-define Package/mountd/description
- openwrt automount daemon
-endef
-
-define Package/mountd/conffiles
-/etc/config/mountd
-endef
-
-define Build/Compile
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(PKG_BUILD_DIR)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
- $(MAKE) -C $(PKG_BUILD_DIR)
-endef
-
-define Package/mountd/install
- $(INSTALL_DIR) $(1)/sbin/ $(1)/etc/config/ $(1)/etc/init.d/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/mountd $(1)/sbin/
- $(INSTALL_DATA) ./files/mountd.config $(1)/etc/config/mountd
- $(INSTALL_BIN) ./files/mountd.init $(1)/etc/init.d/mountd
-endef
-
-$(eval $(call BuildPackage,mountd))