aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-01 21:29:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-01 21:29:10 +0000
commit9b19c72b56b362dab2b4c0a3903a0f3c87d75ed8 (patch)
tree273ed05b101ee0f80a20db4ddce23b618d397cb0 /package/madwifi
parent273b8a2100d0fe3eb6a6d21674b3501603290549 (diff)
downloadupstream-9b19c72b56b362dab2b4c0a3903a0f3c87d75ed8.tar.gz
upstream-9b19c72b56b362dab2b4c0a3903a0f3c87d75ed8.tar.bz2
upstream-9b19c72b56b362dab2b4c0a3903a0f3c87d75ed8.zip
madwifi: remove the get_arch.mk build failure when the 'detected' arch doesn't match the build system's value
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17084 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/madwifi')
-rw-r--r--package/madwifi/patches/106-get_arch.patch7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/madwifi/patches/106-get_arch.patch b/package/madwifi/patches/106-get_arch.patch
index 4873271138..3140f36799 100644
--- a/package/madwifi/patches/106-get_arch.patch
+++ b/package/madwifi/patches/106-get_arch.patch
@@ -1,6 +1,6 @@
--- a/scripts/get_arch.mk
+++ b/scripts/get_arch.mk
-@@ -36,6 +36,13 @@ ifeq (,$(ARCH-y))
+@@ -36,11 +36,14 @@ ifeq (,$(ARCH-y))
$(Cannot determine ARCH)
endif
@@ -14,3 +14,8 @@
# Don't allow ARCH to be overridden by a different value.
ifeq (,$(ARCH))
ARCH = $(ARCH-y)
+-else
+-ifneq ($(ARCH),$(ARCH-y))
+-$(error ARCH mismatch: supplied "$(ARCH)", determined "$(ARCH-y)")
+-endif
+ endif