aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-09-05 23:27:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-09-05 23:27:27 +0000
commita57f7e3b1a48999cbff0bde10f6f0ee5352e2651 (patch)
tree101817e060c5abe9f20fa998e4dda9b526f62cab /package/madwifi
parent155c2fde2c15693932ac7fc172a49ecd3dae1ff4 (diff)
downloadupstream-a57f7e3b1a48999cbff0bde10f6f0ee5352e2651.tar.gz
upstream-a57f7e3b1a48999cbff0bde10f6f0ee5352e2651.tar.bz2
upstream-a57f7e3b1a48999cbff0bde10f6f0ee5352e2651.zip
madwifi: select the right hal binary for EABI on ARM
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12540 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/madwifi')
-rw-r--r--package/madwifi/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 68bec3014a..a0934691ea 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -76,19 +76,19 @@ ifeq ($(ARCH),i686)
HAL_TARGET:=i386-elf
endif
ifeq ($(BOARD),ixp4xx)
- HAL_TARGET:=xscale-be-elf
+ HAL_TARGET:=xscale-be-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
endif
ifeq ($(BOARD),iop32x)
- HAL_TARGET:=xscale-le-elf
+ HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
endif
ifeq ($(BOARD),orion)
- HAL_TARGET:=xscale-le-elf
+ HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
endif
ifeq ($(ARCH),powerpc)
HAL_TARGET:=powerpc-be-elf
endif
ifeq ($(BOARD),storm)
- HAL_TARGET:=armv4-le-elf
+ HAL_TARGET:=armv4-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
endif
ifneq ($(CONFIG_TARGET_atheros),)
HAL_TARGET:=wisoc