aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-16 10:34:21 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-16 10:34:21 +0000
commit6d3fdb1415b571951c7449a455591963b8b3f28e (patch)
treedf840b4761fc794bec1305814652df8575c868d4 /package/madwifi
parent3ad1a02aa966e88d34b30d4f0480042d1c5e8a16 (diff)
downloadupstream-6d3fdb1415b571951c7449a455591963b8b3f28e.tar.gz
upstream-6d3fdb1415b571951c7449a455591963b8b3f28e.tar.bz2
upstream-6d3fdb1415b571951c7449a455591963b8b3f28e.zip
package/madwifi: move configuration in submenu
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20911 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/madwifi')
-rw-r--r--package/madwifi/Config.in10
-rw-r--r--package/madwifi/Makefile1
2 files changed, 6 insertions, 5 deletions
diff --git a/package/madwifi/Config.in b/package/madwifi/Config.in
index 7f1e36d042..7b72eb854e 100644
--- a/package/madwifi/Config.in
+++ b/package/madwifi/Config.in
@@ -1,13 +1,13 @@
-# MadWifi configuration
+menu "Configuration"
+ depends on PACKAGE_kmod-madwifi
config MADWIFI_DEBUG
bool "Enable compilation of debugging features"
- depends on DEVEL && PACKAGE_kmod-madwifi
+ depends on DEVEL
default n
config MADWIFI_COMPRESSION
bool "Enable Atheros Super A/G Compression"
- depends on PACKAGE_kmod-madwifi
depends !TARGET_ar71xx
default n
help
@@ -15,7 +15,6 @@ config MADWIFI_COMPRESSION
config MADWIFI_SINGLE_MODULE
bool "Combine driver and net80211 into a single module"
- depends on PACKAGE_kmod-madwifi
default y
help
This option combines all driver and stack related code (except for HAL)
@@ -24,7 +23,6 @@ config MADWIFI_SINGLE_MODULE
choice
prompt "Rate control algorithm selection"
- depends on PACKAGE_kmod-madwifi
default MADWIFI_RCA_MINSTREL
help
This option controls how MadWifi chooses its bitrate.
@@ -53,3 +51,5 @@ config MADWIFI_RCA_SAMPLERATE
average transmission time.
endchoice
+
+endmenu
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 4c8415a6be..4f01f008fd 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -165,6 +165,7 @@ define KernelPackage/madwifi
DEPENDS:=+wireless-tools @LINUX_2_6 @PCI_SUPPORT @(!(TARGET_avr32||TARGET_cobalt||TARGET_ep93xx||TARGET_etrax||TARGET_octeon||TARGET_pxcab||TARGET_sibyte)||BROKEN)
FILES:=$(MADWIFI_FILES)
AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
+ MENU:=1
endef
define KernelPackage/madwifi/description