aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-02 22:28:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-02 22:28:14 +0000
commit9c7edf0ad03b39f7571bad2c92df133c8c2f78c8 (patch)
treef2c0256a4fd0e0cf3b1ba79ca1855bd993619791 /package/madwifi/Makefile
parent93df90ed3eb240d9d88c983fd74a23a5dbffe5d3 (diff)
downloadupstream-9c7edf0ad03b39f7571bad2c92df133c8c2f78c8.tar.gz
upstream-9c7edf0ad03b39f7571bad2c92df133c8c2f78c8.tar.bz2
upstream-9c7edf0ad03b39f7571bad2c92df133c8c2f78c8.zip
update madwifi to the madwifi-dfs branch - should fix a few ad-hoc mode issues, needs more testing
SVN-Revision: 9648
Diffstat (limited to 'package/madwifi/Makefile')
-rw-r--r--package/madwifi/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 0815c52d3b..117720fa4c 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -10,13 +10,16 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=madwifi
-PKG_VERSION:=r2978-20071127
-PKG_BRANCH:=madwifi-ng
+PKG_REV:=2996
+PKG_VERSION:=r$(PKG_REV)
+PKG_BRANCH:=madwifi-dfs
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_BRANCH)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_BRANCH)
-PKG_MD5SUM:=53d7e7c60caa4d613cf43763e33ce874
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://svn.madwifi.org/madwifi/$(if $(PKG_BRANCH),branches/$(PKG_BRANCH),trunk)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BRANCH)-$(PKG_VERSION)