aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2008-08-30 09:59:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2008-08-30 09:59:00 +0000
commitcee791127b9a6cdcb3de9ca27334ca2a9eee8a70 (patch)
tree03b204bf0737d393193c1b8fdb5aadbca135d783 /package/madwifi/Makefile
parent89217cd88d4cf77b05ac4ae03e6bcba96eb25e1a (diff)
downloadupstream-cee791127b9a6cdcb3de9ca27334ca2a9eee8a70.tar.gz
upstream-cee791127b9a6cdcb3de9ca27334ca2a9eee8a70.tar.bz2
upstream-cee791127b9a6cdcb3de9ca27334ca2a9eee8a70.zip
fix madwifi hal target for mips*
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12435 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/madwifi/Makefile')
-rw-r--r--package/madwifi/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 699a4afd0a..adfd418b20 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -54,11 +54,20 @@ ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
BUS:=
endif
-ifeq ($(ARCH),mips)
- HAL_TARGET:=mips-be-elf
-endif
-ifeq ($(ARCH),mipsel)
- HAL_TARGET:=mips-le-elf
+ifneq ($(CONFIG_CPU_MIPS32_R2),)
+ ifeq ($(ARCH),mips)
+ HAL_TARGET:=mips32r2-be-elf
+ endif
+ ifeq ($(ARCH),mipsel)
+ HAL_TARGET:=mips32r2-le-elf
+ endif
+else
+ ifeq ($(ARCH),mips)
+ HAL_TARGET:=mips32-be-elf
+ endif
+ ifeq ($(ARCH),mipsel)
+ HAL_TARGET:=mips32-le-elf
+ endif
endif
ifeq ($(ARCH),i386)
HAL_TARGET:=i386-elf