aboutsummaryrefslogtreecommitdiffstats
path: root/package/madwifi/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-12-02 22:28:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-12-02 22:28:14 +0000
commit9b4a544391af58f004c3c5dcc026d65ce8e54384 (patch)
tree251d0439db575209e6a42e9d8546b0724c571b5c /package/madwifi/Makefile
parentc921ad681bdbc2ee7a0aa41cc710ed1ea02a6609 (diff)
downloadupstream-9b4a544391af58f004c3c5dcc026d65ce8e54384.tar.gz
upstream-9b4a544391af58f004c3c5dcc026d65ce8e54384.tar.bz2
upstream-9b4a544391af58f004c3c5dcc026d65ce8e54384.zip
update madwifi to the madwifi-dfs branch - should fix a few ad-hoc mode issues, needs more testing
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/madwifi/Makefile')
-rw-r--r--package/madwifi/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 0815c52d3b..117720fa4c 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -10,13 +10,16 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=madwifi
-PKG_VERSION:=r2978-20071127
-PKG_BRANCH:=madwifi-ng
+PKG_REV:=2996
+PKG_VERSION:=r$(PKG_REV)
+PKG_BRANCH:=madwifi-dfs
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_BRANCH)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_BRANCH)
-PKG_MD5SUM:=53d7e7c60caa4d613cf43763e33ce874
+PKG_SOURCE_PROTO:=svn
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(if $(PKG_BRANCH),$(PKG_BRANCH),madwifi)-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://svn.madwifi.org/madwifi/$(if $(PKG_BRANCH),branches/$(PKG_BRANCH),trunk)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BRANCH)-$(PKG_VERSION)