aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-21 13:33:11 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-21 13:33:11 +0000
commit2559d4ca3287ee778b14e6a731746dcc5dc4e646 (patch)
treef0c6639bbd5f9af484de2927ee54ea6301a771b1 /package/mac80211
parent4c134d64ea41f93eb30da2c640ef6c1984e31afe (diff)
downloadupstream-2559d4ca3287ee778b14e6a731746dcc5dc4e646.tar.gz
upstream-2559d4ca3287ee778b14e6a731746dcc5dc4e646.tar.bz2
upstream-2559d4ca3287ee778b14e6a731746dcc5dc4e646.zip
[package] mac80211: fix reversed WARN_ON() condition which causes a stray stacktrace on boot
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29284 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211')
-rw-r--r--package/mac80211/Makefile2
-rw-r--r--package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 25df7aa319..aa729414a2 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -40,6 +40,8 @@ PKG_CONFIG_DEPENDS:= \
CARL9170_FW_VERSION:=1.9.4
+#QUILT_PATCH_DIR:=patches-openwrt
+
include $(INCLUDE_DIR)/package.mk
WMENU:=Wireless Drivers
diff --git a/package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch b/package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch
new file mode 100644
index 0000000000..b5985741ca
--- /dev/null
+++ b/package/mac80211/patches/910-fix-reversed-warn-on-workqueue.patch
@@ -0,0 +1,11 @@
+--- a/compat/compat-2.6.36.c
++++ b/compat/compat-2.6.36.c
+@@ -101,7 +101,7 @@ EXPORT_SYMBOL_GPL(system_nrt_wq);
+ void compat_system_workqueue_create()
+ {
+ system_nrt_wq = create_singlethread_workqueue("events_nrt");
+- WARN_ON(system_nrt_wq);
++ WARN_ON(!system_nrt_wq);
+ }
+
+ void compat_system_workqueue_destroy()