aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-11-13 17:11:43 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-11-13 17:11:43 +0000
commit13bf4626dbda4a5a4e063c72f5b48cd097f61d9d (patch)
treef5b6d177325649e72852f18a25bb325ea667388c /package/mac80211
parentf92973072d9e58503a70ff48e2e41fb47a9bcbb8 (diff)
downloadupstream-13bf4626dbda4a5a4e063c72f5b48cd097f61d9d.tar.gz
upstream-13bf4626dbda4a5a4e063c72f5b48cd097f61d9d.tar.bz2
upstream-13bf4626dbda4a5a4e063c72f5b48cd097f61d9d.zip
package/mac80211: add config option to enable Atheros wireless debugging
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18412 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211')
-rw-r--r--package/mac80211/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 5e99342b79..13d1670a3e 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2009-11-03
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:= \
http://www.orbit-lab.org/kernel/compat-wireless-2.6/2009/11 \
http://wireless.kernel.org/download/compat-wireless-2.6
@@ -278,10 +278,17 @@ config ATH_USER_REGD
help
Atheros' idea of regulatory handling is that the EEPROM of the card defines
the regulatory limits and the user is only allowed to restrict the settings
- even further, even if the country allows frequencies or power levels that
+ even further, even if the country allows frequencies or power levels that
are forbidden by the EEPROM settings.
Select this option if you want the driver to respect the user's decision about
regulatory settings.
+
+config PACKAGE_ATH_DEBUG
+ bool "Atheros wireless debugging"
+ depends on PACKAGE_kmod-ath
+ help
+ Say Y, if you want to debug atheros wireless drivers.
+ Right now only ath9k makes use of this.
endef
define KernelPackage/ath
@@ -492,6 +499,7 @@ BUILDFLAGS:= \
-DCONFIG_B43_HWRNG -DCONFIG_B43LEGACY_HWRNG \
$(if $(CONFIG_PACKAGE_MAC80211_DEBUGFS),-DCONFIG_MAC80211_DEBUGFS) \
$(if $(CONFIG_PACKAGE_ATH9K_DEBUG),-DCONFIG_ATH9K_DEBUG) \
+ $(if $(CONFIG_PACKAGE_ATH_DEBUG),-DCONFIG_ATH_DEBUG) \
-D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
$(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1)
@@ -518,6 +526,7 @@ MAKE_OPTS:= \
CONFIG_B43=$(if $(CONFIG_PACKAGE_kmod-b43),m) \
CONFIG_B43LEGACY=$(if $(CONFIG_PACKAGE_kmod-b43legacy),m) \
CONFIG_ATH_COMMON=$(if $(CONFIG_PACKAGE_kmod-ath),m) \
+ CONFIG_ATH_DEBUG=$(if $(CONFIG_PACKAGE_ATH_DEBUG),y) \
CONFIG_ATH5K=$(if $(CONFIG_PACKAGE_kmod-ath5k),m) \
CONFIG_ATH9K=$(if $(CONFIG_PACKAGE_kmod-ath9k),m) \
CONFIG_ATH9K_DEBUG=$(if $(CONFIG_PACKAGE_ATH9K_DEBUG),y) \