aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/400-ath_move_debug_code.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-07-12 08:19:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-07-12 08:19:04 +0000
commitd1af787dc992741bffa1a1ce0b4ca7eacb1f7227 (patch)
treeb4d150683b180b04da569f049a53d592956d705b /package/mac80211/patches/400-ath_move_debug_code.patch
parent700de21fec69cc8b11374be00d04660ffbd48943 (diff)
downloadupstream-d1af787dc992741bffa1a1ce0b4ca7eacb1f7227.tar.gz
upstream-d1af787dc992741bffa1a1ce0b4ca7eacb1f7227.tar.bz2
upstream-d1af787dc992741bffa1a1ce0b4ca7eacb1f7227.zip
mac80211: backport latest version from trunk (as of r37265)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@37266 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches/400-ath_move_debug_code.patch')
-rw-r--r--package/mac80211/patches/400-ath_move_debug_code.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/mac80211/patches/400-ath_move_debug_code.patch b/package/mac80211/patches/400-ath_move_debug_code.patch
index c91128db61..aa5ce94d1e 100644
--- a/package/mac80211/patches/400-ath_move_debug_code.patch
+++ b/package/mac80211/patches/400-ath_move_debug_code.patch
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/ath/Makefile
+++ b/drivers/net/wireless/ath/Makefile
-@@ -10,7 +10,7 @@ obj-$(CONFIG_ATH_COMMON) += ath.o
+@@ -11,7 +11,7 @@ obj-$(CPTCFG_ATH_COMMON) += ath.o
ath-objs := main.o \
regd.o \
hw.o \
@@ -8,15 +8,15 @@
+ key.o \
+ debug.o
--ath-$(CONFIG_ATH_DEBUG) += debug.o
+-ath-$(CPTCFG_ATH_DEBUG) += debug.o
ccflags-y += -D__CHECK_ENDIAN__
--- a/drivers/net/wireless/ath/ath.h
+++ b/drivers/net/wireless/ath/ath.h
-@@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
- #endif /* CONFIG_ATH_DEBUG */
+@@ -280,13 +280,6 @@ void _ath_dbg(struct ath_common *common,
+ #endif /* CPTCFG_ATH_DEBUG */
/** Returns string describing opmode, or NULL if unknown mode. */
--#ifdef CONFIG_ATH_DEBUG
+-#ifdef CPTCFG_ATH_DEBUG
const char *ath_opmode_to_string(enum nl80211_iftype opmode);
-#else
-static inline const char *ath_opmode_to_string(enum nl80211_iftype opmode)