aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/400-ath_move_debug_code.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-02-07 11:28:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-02-07 11:28:11 +0000
commit2119054b0a501a065a656f106d3fec11f0c854d3 (patch)
tree591965ae3e7e4671400eff996096b8f4545d7338 /package/mac80211/patches/400-ath_move_debug_code.patch
parenta633639fe6e9486f9403914cded6aff130c2e973 (diff)
downloadupstream-2119054b0a501a065a656f106d3fec11f0c854d3.tar.gz
upstream-2119054b0a501a065a656f106d3fec11f0c854d3.tar.bz2
upstream-2119054b0a501a065a656f106d3fec11f0c854d3.zip
mac80211: update to wireless-testing 2012-02-06
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30346 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/patches/400-ath_move_debug_code.patch')
-rw-r--r--package/mac80211/patches/400-ath_move_debug_code.patch9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/mac80211/patches/400-ath_move_debug_code.patch b/package/mac80211/patches/400-ath_move_debug_code.patch
index c322dd3e5b..69bb0f6806 100644
--- a/package/mac80211/patches/400-ath_move_debug_code.patch
+++ b/package/mac80211/patches/400-ath_move_debug_code.patch
@@ -1,17 +1,18 @@
--- a/drivers/net/wireless/ath/Makefile
+++ b/drivers/net/wireless/ath/Makefile
-@@ -8,6 +8,5 @@ obj-$(CONFIG_ATH_COMMON) += ath.o
+@@ -8,7 +8,7 @@ obj-$(CONFIG_ATH_COMMON) += ath.o
ath-objs := main.o \
regd.o \
hw.o \
- key.o
--
--ath-$(CONFIG_ATH_DEBUG) += debug.o
+ key.o \
+ debug.o
+
+-ath-$(CONFIG_ATH_DEBUG) += debug.o
+ ccflags-y += -D__CHECK_ENDIAN__
--- a/drivers/net/wireless/ath/ath.h
+++ b/drivers/net/wireless/ath/ath.h
-@@ -272,13 +272,6 @@ void ath_dbg(struct ath_common *common,
+@@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
#endif /* CONFIG_ATH_DEBUG */
/** Returns string describing opmode, or NULL if unknown mode. */