aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/110-disable_usb_compat.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-12-06 14:11:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-12-06 14:11:09 +0000
commit3e5940532d864795e4081585c6200a93d12cbd47 (patch)
treec7db81accaba2b13ed9ee94133d6b93e822acaae /package/mac80211/patches/110-disable_usb_compat.patch
parent85ce5212fe946a07366f10067ae42c8f004f85ce (diff)
downloadupstream-3e5940532d864795e4081585c6200a93d12cbd47.tar.gz
upstream-3e5940532d864795e4081585c6200a93d12cbd47.tar.bz2
upstream-3e5940532d864795e4081585c6200a93d12cbd47.zip
mac80211: clean up patches, replace patching config.mk with a generated sed expression
SVN-Revision: 34531
Diffstat (limited to 'package/mac80211/patches/110-disable_usb_compat.patch')
-rw-r--r--package/mac80211/patches/110-disable_usb_compat.patch44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/mac80211/patches/110-disable_usb_compat.patch b/package/mac80211/patches/110-disable_usb_compat.patch
deleted file mode 100644
index d6287fd045..0000000000
--- a/package/mac80211/patches/110-disable_usb_compat.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/compat/compat-2.6.28.c
-+++ b/compat/compat-2.6.28.c
-@@ -165,7 +165,7 @@ EXPORT_SYMBOL_GPL(pcmcia_loop_config);
-
- #endif /* CONFIG_PCMCIA */
-
--#if defined(CONFIG_USB) || defined(CONFIG_USB_MODULE)
-+#if 0
-
- void usb_unpoison_urb(struct urb *urb)
- {
---- a/compat/compat-2.6.29.c
-+++ b/compat/compat-2.6.29.c
-@@ -49,7 +49,7 @@ void netdev_attach_ops(struct net_device
- EXPORT_SYMBOL_GPL(netdev_attach_ops);
-
- #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
--#if defined(CONFIG_USB) || defined(CONFIG_USB_MODULE)
-+#if 0
- /**
- * usb_unpoison_anchored_urbs - let an anchor be used successfully again
- * @anchor: anchor the requests are bound to
---- a/include/linux/compat-2.6.28.h
-+++ b/include/linux/compat-2.6.28.h
-@@ -74,7 +74,7 @@ int pcmcia_loop_config(struct pcmcia_dev
- /* USB anchors were added as of 2.6.23 */
- #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23))
-
--#if defined(CONFIG_USB) || defined(CONFIG_USB_MODULE)
-+#if 0
- #if 0
- extern void usb_poison_urb(struct urb *urb);
- #endif
---- a/config.mk
-+++ b/config.mk
-@@ -510,7 +510,7 @@ endif #CONFIG_COMPAT_KERNEL_2_6_29
- # This activates a threading fix for usb urb.
- # this is mainline commit: b3e670443b7fb8a2d29831b62b44a039c283e351
- # This fix will be included in some stable releases.
--export CONFIG_COMPAT_USB_URB_THREAD_FIX=y
-+# export CONFIG_COMPAT_USB_URB_THREAD_FIX=y
-
- export CONFIG_ATH9K_HTC=m
- # export CONFIG_ATH9K_HTC_DEBUGFS=y