aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2009-12-26 23:15:16 +0000
committerHauke Mehrtens <hauke@openwrt.org>2009-12-26 23:15:16 +0000
commitb1efecf94bbf2c4b5106f3a7846d1008105fafd7 (patch)
tree387e01d2788cb52e46e18782eab391c401a162e9 /package/mac80211/Makefile
parent76c9220efaf46f8fe762a9f86dc4c35f517c396e (diff)
downloadupstream-b1efecf94bbf2c4b5106f3a7846d1008105fafd7.tar.gz
upstream-b1efecf94bbf2c4b5106f3a7846d1008105fafd7.tar.bz2
upstream-b1efecf94bbf2c4b5106f3a7846d1008105fafd7.zip
[mac80211] b43 and b43legacy: squash firmware
Only G and L-PHY are supportted by b43 driver Add squash firmware for b43legacy git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18947 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 4cef285942..d500ed9b2e 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -489,6 +489,10 @@ $(call KernelPackage/b43-common)
AUTOLOAD:=$(call AutoLoad,30,b43legacy)
endef
+define KernelPackage/b43legacy/config
+ source "$(SOURCE)/Config.in.b43legacy"
+endef
+
define KernelPackage/b43legacy/description
Kernel module for Broadcom 43xx-legacy wireless support (mac80211 stack) new
endef
@@ -712,6 +716,9 @@ define KernelPackage/b43legacy/install
$(INSTALL_DIR) $(1)/lib/firmware/
b43-fwcutter --unsupported -w $(1)/lib/firmware/ $(DL_DIR)/$(PKG_B43_FWV3_SOURCE)
+ifneq ($(CONFIG_B43LEGACY_FW_SQUASH),)
+ b43-fwsquash.py "G" "$(CONFIG_B43LEGACY_FW_SQUASH_COREREVS)" "$(1)/lib/firmware/b43legacy"
+endif
endef
$(eval $(call KernelPackage,ath5k))