aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2012-08-05 23:43:36 +0000
committerHauke Mehrtens <hauke@openwrt.org>2012-08-05 23:43:36 +0000
commitebdd990be59ec4e00995c8a49e62f2ebbea3e3d7 (patch)
treedd1c78c421ae151210a30e7615b89ce343a44b56 /package/mac80211/Makefile
parent61b89035c3990d6a7c6c028b68c9056bd0df554d (diff)
downloadupstream-ebdd990be59ec4e00995c8a49e62f2ebbea3e3d7.tar.gz
upstream-ebdd990be59ec4e00995c8a49e62f2ebbea3e3d7.tar.bz2
upstream-ebdd990be59ec4e00995c8a49e62f2ebbea3e3d7.zip
[packages] mac80211: remove header files used to share struct with platform code.
The structs defined in these header files should be the same as the structes used by the platform code otherwise it will cause strange runtime errors. By removing them from compat-wireless we will get a compile error instead of a runtime error if they are out of sync. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33006 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index a6738af768..f1a797e607 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -1329,7 +1329,13 @@ define Build/Prepare
$(TAR) -C $(PKG_BUILD_DIR) -xjf $(DL_DIR)/$(PKG_LINUX_FIRMWARE_SOURCE)
rm -rf $(PKG_BUILD_DIR)/include/linux/ssb
rm -rf $(PKG_BUILD_DIR)/include/linux/bcma
+ rm -rf $(PKG_BUILD_DIR)/include/net/bluetooth/
rm -f $(PKG_BUILD_DIR)/include/linux/eeprom_93cx6.h
+ rm -f $(PKG_BUILD_DIR)/include/linux/ath9k_platform.h
+ rm -f $(PKG_BUILD_DIR)/include/linux/ath5k_platform.h
+ rm -f $(PKG_BUILD_DIR)/include/linux/rt2x00_platform.h
+ rm -f $(PKG_BUILD_DIR)/include/linux/wl12xx.h
+ rm -f $(PKG_BUILD_DIR)/include/linux/spi/libertas_spi.h
rm -f $(PKG_BUILD_DIR)/include/net/ieee80211.h
echo 'compat-wireless-$(PKG_VERSION)-$(PKG_RELEASE)-$(REVISION)' > $(PKG_BUILD_DIR)/compat_version
$(CP) ./files/regdb.txt $(PKG_BUILD_DIR)/net/wireless/db.txt