aboutsummaryrefslogtreecommitdiffstats
path: root/package/lua
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-29 11:38:22 +0000
committerSteven Barth <steven@midlink.org>2008-06-29 11:38:22 +0000
commit9e5e864db3996db06355d6021153a51861832ee5 (patch)
tree9567ad9ae55e12463738bd2da0403849d9a0803b /package/lua
parentc5ee6874dcb51a01410de1b06c0bde433f1abc48 (diff)
downloadupstream-9e5e864db3996db06355d6021153a51861832ee5.tar.gz
upstream-9e5e864db3996db06355d6021153a51861832ee5.tar.bz2
upstream-9e5e864db3996db06355d6021153a51861832ee5.zip
lua: Fixed some cross-platform issues for PPC (and probably other architectures)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11608 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/lua')
-rw-r--r--package/lua/Makefile4
-rw-r--r--package/lua/patches/015-lnum-ppc-compat.patch13
2 files changed, 15 insertions, 2 deletions
diff --git a/package/lua/Makefile b/package/lua/Makefile
index e5ac938c0e..c7706376dd 100644
--- a/package/lua/Makefile
+++ b/package/lua/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lua
PKG_VERSION:=5.1.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@@ -96,7 +96,7 @@ define Build/Compile
AR="$(TARGET_CROSS)ar rcu" \
RANLIB="$(TARGET_CROSS)ranlib" \
INSTALL_ROOT=/usr \
- CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+ CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -fPIC" \
MYLDFLAGS="$(TARGET_LDFLAGS)" \
PKG_VERSION=$(PKG_VERSION) \
all linux
diff --git a/package/lua/patches/015-lnum-ppc-compat.patch b/package/lua/patches/015-lnum-ppc-compat.patch
new file mode 100644
index 0000000000..d6c48a7758
--- /dev/null
+++ b/package/lua/patches/015-lnum-ppc-compat.patch
@@ -0,0 +1,13 @@
+Index: lua-5.1.3/src/lua.h
+===================================================================
+--- lua-5.1.3.orig/src/lua.h 2008-06-29 11:45:55.000000000 +0200
++++ lua-5.1.3/src/lua.h 2008-06-29 11:46:28.000000000 +0200
+@@ -79,7 +79,7 @@
+ * not acceptable for 5.1, maybe 5.2 onwards?
+ * 9: greater than existing (5.1) type values.
+ */
+-#define LUA_TINT (-2)
++#define LUA_TINT 9
+
+ #define LUA_TNIL 0
+ #define LUA_TBOOLEAN 1