aboutsummaryrefslogtreecommitdiffstats
path: root/package/lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-10-28 00:11:59 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-10-28 00:11:59 +0000
commit04f57c7f8708ed3f81199e01beb600159918fec7 (patch)
tree0f21192f1f8d13ad4a7438043896f0e69835129c /package/lua
parentd8c2ea357777457daa10ebbc2512c5012d9b37ea (diff)
downloadupstream-04f57c7f8708ed3f81199e01beb600159918fec7.tar.gz
upstream-04f57c7f8708ed3f81199e01beb600159918fec7.tar.bz2
upstream-04f57c7f8708ed3f81199e01beb600159918fec7.zip
[package] lua: the variable expansion to detect the host os does not work with GNU Make 3.81, replace it with a nested ifeq
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18193 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/lua')
-rw-r--r--package/lua/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/package/lua/Makefile b/package/lua/Makefile
index 9d9c77b9e4..c8c64badf4 100644
--- a/package/lua/Makefile
+++ b/package/lua/Makefile
@@ -115,10 +115,15 @@ define Host/Configure
$(SED) 's,"/usr/local/","$(STAGING_DIR_HOST)/",' $(HOST_BUILD_DIR)/src/luaconf.h
endef
-LUA_OS.Darwin:=macosx
-LUA_OS.FreeBSD:=freebsd
-LUA_OS:=$(LUA_OS.$(HOST_OS))
-LUA_OS?=linux
+ifeq ($(HOST_OS),Darwin)
+ LUA_OS:=macosx
+else
+ ifeq ($(HOST_OS),FreeBSD)
+ LUA_OS:=freebsd
+ else
+ LUA_OS:=linux
+ endif
+endif
define Host/Compile
$(MAKE) -C $(HOST_BUILD_DIR) \