aboutsummaryrefslogtreecommitdiffstats
path: root/package/lua/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-01-31 07:18:13 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-01-31 07:18:13 +0000
commit4a21b1be1ab6dc7bd0424af408f91c65cb5316d8 (patch)
treec30dfb756241d00a065ac7d7a715147f1ece3da0 /package/lua/Makefile
parentc619bb12e3cb8896b444e9c77922f707859b98b7 (diff)
downloadupstream-4a21b1be1ab6dc7bd0424af408f91c65cb5316d8.tar.gz
upstream-4a21b1be1ab6dc7bd0424af408f91c65cb5316d8.tar.bz2
upstream-4a21b1be1ab6dc7bd0424af408f91c65cb5316d8.zip
fix lua compile with eglibc selected and utmp support disabled
SVN-Revision: 14298
Diffstat (limited to 'package/lua/Makefile')
-rw-r--r--package/lua/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/lua/Makefile b/package/lua/Makefile
index aff52c3f24..eff31390af 100644
--- a/package/lua/Makefile
+++ b/package/lua/Makefile
@@ -86,6 +86,12 @@ endef
TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC)
+ifneq ($(CONFIG_USE_EGLIBC),)
+ ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
+ TARGET_CFLAGS += -DNO_GETLOGIN
+ endif
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CROSS)gcc" \