aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-tapi
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-07-06 13:41:16 +0000
committerJohn Crispin <blogic@openwrt.org>2011-07-06 13:41:16 +0000
commit34bb4ecdec53f23cd47eee7fd4c50ed6bb1e0322 (patch)
tree5925e63343459c20b4ed177f8b9d2bff6c743e15 /package/ltq-tapi
parent8edd80ec9c46dc0124b40cd4914c2bd7dc0a7422 (diff)
downloadupstream-34bb4ecdec53f23cd47eee7fd4c50ed6bb1e0322.tar.gz
upstream-34bb4ecdec53f23cd47eee7fd4c50ed6bb1e0322.tar.bz2
upstream-34bb4ecdec53f23cd47eee7fd4c50ed6bb1e0322.zip
Lantiq TAPI driver also build for other platforms
thanks Matthias Buecher git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27494 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ltq-tapi')
-rw-r--r--package/ltq-tapi/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/ltq-tapi/Makefile b/package/ltq-tapi/Makefile
index ecaac2eeb4..656ae15050 100644
--- a/package/ltq-tapi/Makefile
+++ b/package/ltq-tapi/Makefile
@@ -22,7 +22,7 @@ define KernelPackage/ltq-tapi
SUBMENU:=Voice over IP
TITLE:=Lantiq TAPI subsystem
URL:=http://www.lantiq.com/
- DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq
+ DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq_xway
FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
MAINTAINER:=John Crispin <blogic@openwrt.org>
@@ -60,10 +60,12 @@ define Build/Configure
$(call Build/Configure/Default)
endef
-define Build/InstallDev
+ifdef CONFIG_TARGET_lantiq
+ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/drv_tapi
$(CP) --dereference $(PKG_BUILD_DIR)/include/* $(1)/usr/include/drv_tapi
(cd $(1)/usr/include/drv_tapi && ln -s . include && ln -s ../ifxos/ifx_types.h .)
-endef
+ endef
+endif
$(eval $(call KernelPackage,ltq-tapi))