aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-kpi2udp/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-02-07 21:48:55 +0000
committerJohn Crispin <blogic@openwrt.org>2011-02-07 21:48:55 +0000
commit65c486c168aef28368d139471539c3b1b1e95053 (patch)
treed53c98517753e8c5c8e527f5439cd61b2c203c0f /package/ltq-kpi2udp/Makefile
parent116b670106681d51fac23d31b80aec695f1759fa (diff)
downloadupstream-65c486c168aef28368d139471539c3b1b1e95053.tar.gz
upstream-65c486c168aef28368d139471539c3b1b1e95053.tar.bz2
upstream-65c486c168aef28368d139471539c3b1b1e95053.zip
[ltq-kpi2udp]
* adss in-kernel udp redirect plugin for lantiq voice optimisation git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25413 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ltq-kpi2udp/Makefile')
-rw-r--r--package/ltq-kpi2udp/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/ltq-kpi2udp/Makefile b/package/ltq-kpi2udp/Makefile
new file mode 100644
index 0000000000..497f743e04
--- /dev/null
+++ b/package/ltq-kpi2udp/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=drv_kpi2udp
+PKG_VERSION:=2.2.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=drv_kpi2udp-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_MD5SUM:=af3855609554c7f3d2c3df8c597f50a7
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/ltq-kpi2udp
+ SUBMENU:=Voice over IP
+ TITLE:=TAPI KPI2UDP plug-in
+ URL:=http://www.lantiq.com/
+ DEPENDS:=+kmod-ltq-tapi @TARGET_lantiq
+ FILES:=$(PKG_BUILD_DIR)/drv_kpi2udp.ko
+ AUTOLOAD:=$(call AutoLoad,26,drv_kpi2udp)
+ MAINTAINER:=John Crispin <blogic@openwrt.org>
+endef
+
+define KernelPackage/ltq-kpi2udp/description
+ RTP packet path accelleration into IP stack (strongly recommended)
+endef
+
+CONFIGURE_ARGS += --enable-kernelincl="$(LINUX_DIR)/include" \
+ --enable-tapiincl="$(STAGING_DIR)/usr/include/drv_tapi" \
+ --with-ifxos-incl=$(STAGING_DIR)/usr/include/ifxos \
+ --enable-warning \
+ --enable-linux-26 \
+ --enable-kernelbuild="$(LINUX_DIR)" \
+ ARCH=$(LINUX_KARCH)
+
+define Build/Configure
+ (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
+ $(call Build/Configure/Default)
+endef
+
+$(eval $(call KernelPackage,ltq-kpi2udp))