aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-dsl-app
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2011-02-01 14:30:38 +0000
committerJohn Crispin <blogic@openwrt.org>2011-02-01 14:30:38 +0000
commit448df0ccf7a79fae3a8aef8882720669fc9f0dc7 (patch)
tree1069d44383ae54ab84f4f9c7c62d9fe8797f4f74 /package/ltq-dsl-app
parent79a047aa996b7e7edb15c14e20d3889850b8039c (diff)
downloadupstream-448df0ccf7a79fae3a8aef8882720669fc9f0dc7.tar.gz
upstream-448df0ccf7a79fae3a8aef8882720669fc9f0dc7.tar.bz2
upstream-448df0ccf7a79fae3a8aef8882720669fc9f0dc7.zip
[ltq-dsl]
* rename lqdsl packages to ltq-dsl * small rework of packages * make it work with latest kernel git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25274 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/ltq-dsl-app')
-rw-r--r--package/ltq-dsl-app/Makefile80
-rw-r--r--package/ltq-dsl-app/files/ifx_cpe_control_init.sh21
2 files changed, 101 insertions, 0 deletions
diff --git a/package/ltq-dsl-app/Makefile b/package/ltq-dsl-app/Makefile
new file mode 100644
index 0000000000..5be052f6e2
--- /dev/null
+++ b/package/ltq-dsl-app/Makefile
@@ -0,0 +1,80 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_BASE_NAME:=dsl_cpe_control_danube
+PKG_VERSION:=3.24.4.4
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ltq-dsl-app
+ SECTION:=net
+ CATEGORY:=Network
+ TITLE:=Lantiq DSL userland tool
+ URL:=http://www.lantiq.com/
+ DEPENDS:=@TARGET_lantiq_xway +kmod-ltq-dsl +libpthread
+ MAINTAINER:=John Crispin <blogic@openwrt.org>
+endef
+
+define Package/ltq-dsl-app/description
+ Infineon DSL CPE API for Amazon SE, Danube and Vinax.
+endef
+
+IFX_DSL_MAX_DEVICE=1
+IFX_DSL_LINES_PER_DEVICE=1
+IFX_DSL_CHANNELS_PER_LINE=1
+#CONFIG_IFX_CLI=y
+
+CONFIGURE_ARGS += \
+ --with-max-device="$(IFX_DSL_MAX_DEVICE)" \
+ --with-lines-per-device="$(IFX_DSL_LINES_PER_DEVICE)" \
+ --with-channels-per-line="$(IFX_DSL_CHANNELS_PER_LINE)" \
+ --enable-danube \
+ --enable-driver-include="-I$(STAGING_DIR)/usr/include" \
+ --enable-debug-prints \
+ --enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
+ --enable-cmv-scripts \
+ --enable-debug-tool-interface \
+ --enable-adsl-led \
+ --enable-dsl-ceoc \
+ --enable-script-notification \
+ --enable-dsl-pm \
+ --enable-dsl-pm-total \
+ --enable-dsl-pm-history \
+ --enable-dsl-pm-showtime \
+ --enable-dsl-pm-channel-counters \
+ --enable-dsl-pm-datapath-counters \
+ --enable-dsl-pm-line-counters \
+ --enable-dsl-pm-channel-thresholds \
+ --enable-dsl-pm-datapath-thresholds \
+ --enable-dsl-pm-line-thresholds \
+ --enable-dsl-pm-optional-parameters
+
+ifeq ($(CONFIG_IFX_CLI),y)
+CONFIGURE_ARGS += \
+ --enable-cli-support \
+ --enable-soap-support
+endif
+
+TARGET_CFLAGS += -I$(LINUX_DIR)/include
+
+define Package/ltq-dsl-app/install
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/ifx_cpe_control_init.sh $(1)/etc/init.d/
+
+ $(INSTALL_DIR) $(1)/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
+endef
+
+$(eval $(call BuildPackage,ltq-dsl-app))
diff --git a/package/ltq-dsl-app/files/ifx_cpe_control_init.sh b/package/ltq-dsl-app/files/ifx_cpe_control_init.sh
new file mode 100644
index 0000000000..91316938ce
--- /dev/null
+++ b/package/ltq-dsl-app/files/ifx_cpe_control_init.sh
@@ -0,0 +1,21 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2008 OpenWrt.org
+START=99
+
+start() {
+
+ # start CPE dsl daemon in the background
+ /sbin/dsl_cpe_control -i -f /lib/firmware/ModemHWE.bin &
+
+# PS=`ps`
+# echo $PS | grep -q dsl_cpe_control && {
+# # workaround for nfs: allow write to pipes for non-root
+# while [ ! -e /tmp/pipe/dsl_cpe1_ack ] ; do sleep 1; done
+# chmod a+w /tmp/pipe/dsl_*
+# }
+ echo $PS | grep -q dsl_cpe_control || {
+ echo "Start of dsl_cpe_control failed!!!"
+ false
+ }
+
+}