aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-dsl-app/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-01-24 11:31:23 +0000
committerJohn Crispin <john@openwrt.org>2012-01-24 11:31:23 +0000
commita558d605ab54313e8217201b67e0dff610db0e0c (patch)
treeb6e4ee2dfbe85ad3fbf12d39bf95f5b2337e1f74 /package/ltq-dsl-app/Makefile
parent17bb00389165d2557498da449489322a200db13c (diff)
downloadupstream-a558d605ab54313e8217201b67e0dff610db0e0c.tar.gz
upstream-a558d605ab54313e8217201b67e0dff610db0e0c.tar.bz2
upstream-a558d605ab54313e8217201b67e0dff610db0e0c.zip
Initial DSL framework
- Removed ifx_cpe_control_init.sh (the old init script) - Created dsl_control (/etc/init.d) - tidied up start and stop - stop calls dsl_notify before killing daemon - has status and lucistat options to provide detail - copes with daemon not running situation - Updated package makefile to use new init script and to build cli support - Provide a dsl_notify.sh script to cope with line up/down events Signed-off-by: Lee Essen <lee.essen@nowonline.co.uk> SVN-Revision: 29881
Diffstat (limited to 'package/ltq-dsl-app/Makefile')
-rw-r--r--package/ltq-dsl-app/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/ltq-dsl-app/Makefile b/package/ltq-dsl-app/Makefile
index 981a6a7961..f94f3e0b99 100644
--- a/package/ltq-dsl-app/Makefile
+++ b/package/ltq-dsl-app/Makefile
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
PKG_MD5SUM:=ee315306626b68794d3d3636dabfe161
PKG_CONFIG_DEPENDS:=\
- CONFIG_LTQ_DSL_ENABLE_CLI \
+ CONFIG_LTQ_DSL_ENABLE_SOAP \
CONFIG_LTQ_DSL_ENABLE_DSL_EVENT_POLLING
include $(INCLUDE_DIR)/package.mk
@@ -55,6 +55,7 @@ CONFIGURE_ARGS += \
--enable-driver-include="-I$(STAGING_DIR)/usr/include" \
--enable-debug-prints \
--enable-add-appl-cflags="-DMAX_CLI_PIPES=2" \
+ --enable-cli-support \
--enable-cmv-scripts \
--enable-debug-tool-interface \
--enable-adsl-led \
@@ -72,9 +73,8 @@ CONFIGURE_ARGS += \
--enable-dsl-pm-line-thresholds \
--enable-dsl-pm-optional-parameters
-ifeq ($(CONFIG_LTQ_DSL_ENABLE_CLI),y)
+ifeq ($(CONFIG_LTQ_DSL_ENABLE_SOAP),y)
CONFIGURE_ARGS += \
- --enable-cli-support \
--enable-soap-support
endif
@@ -87,10 +87,11 @@ TARGET_CFLAGS += -I$(LINUX_DIR)/include
define Package/ltq-dsl-app/install
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/ifx_cpe_control_init.sh $(1)/etc/init.d/
+ $(INSTALL_BIN) ./files/dsl_control $(1)/etc/init.d/
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
+ $(INSTALL_BIN) ./files/dsl_notify.sh $(1)/sbin
endef
$(eval $(call BuildPackage,ltq-dsl-app))