aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-21 02:14:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-21 02:14:50 +0000
commit3133fefe06562d0ce7984230425128634de27f2f (patch)
tree8df13d10fa44e4a5f514430f10185173143cee39 /package/linux-atm
parent69d76bb482633a1f0af1dc635a3286062e0397cf (diff)
downloadupstream-3133fefe06562d0ce7984230425128634de27f2f.tar.gz
upstream-3133fefe06562d0ce7984230425128634de27f2f.tar.bz2
upstream-3133fefe06562d0ce7984230425128634de27f2f.zip
pass the CFLAGS through the environment on compile and fix a few packages
SVN-Revision: 6154
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index 9aae0a0b0e..7691c1149a 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -51,11 +51,12 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/stamp-h.in
endef
+TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/src/include $(TARGET_CFLAGS)
define Build/Compile
- $(call Build/Compile/Default, \
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(TARGET_CONFIGURE_OPTS) \
DESTDIR="$(PKG_INSTALL_DIR)" \
- all install \
- )
+ all install
endef
define Build/InstallDev