aboutsummaryrefslogtreecommitdiffstats
path: root/package/linux-atm
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-03-28 21:41:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-03-28 21:41:56 +0000
commite102683bc23cae025fdd72cdd702005d2a8394d2 (patch)
tree64c0b6c3ca3d355ee3c513d8965530eec90f9748 /package/linux-atm
parent87821d2cdd9fd0500d7dd2144fdbbb08077cc28c (diff)
downloadupstream-e102683bc23cae025fdd72cdd702005d2a8394d2.tar.gz
upstream-e102683bc23cae025fdd72cdd702005d2a8394d2.tar.bz2
upstream-e102683bc23cae025fdd72cdd702005d2a8394d2.zip
linux-atm: add the kernel include dir to the cflags and move the build dir to $(KERNEL_BUILD_DIR) to ensure that target specific ATM API changes are included
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20556 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/linux-atm')
-rw-r--r--package/linux-atm/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/linux-atm/Makefile b/package/linux-atm/Makefile
index 07484c675f..c8a18c3d31 100644
--- a/package/linux-atm/Makefile
+++ b/package/linux-atm/Makefile
@@ -6,6 +6,7 @@
#
include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=linux-atm
PKG_VERSION:=2.5.1
@@ -46,6 +47,8 @@ define Build/Configure
touch $(PKG_BUILD_DIR)/stamp-h.in
endef
+TARGET_CFLAGS += -I$(LINUX_DIR)/include
+
define Build/Compile
# src/qgen is built with HOSTCC, which does not really like our LDFLAGS
$(MAKE) -C $(PKG_BUILD_DIR)/src/qgen \